summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-aria2/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-09-19 13:31:25 +0300
committerGitHub <noreply@github.com>2016-09-19 13:31:25 +0300
commit51e087e55ff0aaadcd8d5f0b50207aba40c48c29 (patch)
treea99e1fa69b5a9c6466f5534ef665ba6392573c35 /applications/luci-app-aria2/Makefile
parent44bf3f0c1640040561306caff39f34ac916b4357 (diff)
parenta4c8c206477b1c8d4fb60dcb73d777c9c9183e81 (diff)
Merge pull request #799 from kuoruan/aria2
luci-app-aria2: fix and update
Diffstat (limited to 'applications/luci-app-aria2/Makefile')
-rw-r--r--applications/luci-app-aria2/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/applications/luci-app-aria2/Makefile b/applications/luci-app-aria2/Makefile
index 0179f04f4c..f5b006c357 100644
--- a/applications/luci-app-aria2/Makefile
+++ b/applications/luci-app-aria2/Makefile
@@ -6,8 +6,32 @@
include $(TOPDIR)/rules.mk
+PKG_NAME:=luci-app-aria2
+
+# Version == major.minor.patch
+# increase "minor" on new functionality and "patch" on patches/optimization
+PKG_VERSION:=1.0.1
+
+# Release == build
+# increase on changes of translation files
+PKG_RELEASE:=2
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Hsing-Wang Liao <kuoruan@gmail.com>
+
+# LuCI specific settings
LUCI_TITLE:=LuCI Support for Aria2
LUCI_DEPENDS:=+aria2
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+ $(PKG_MAINTAINER)
+endef
include ../../luci.mk