summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-ahcp/luasrc/view/ahcp_status.htm
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /applications/luci-app-ahcp/luasrc/view/ahcp_status.htm
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'applications/luci-app-ahcp/luasrc/view/ahcp_status.htm')
-rw-r--r--applications/luci-app-ahcp/luasrc/view/ahcp_status.htm53
1 files changed, 53 insertions, 0 deletions
diff --git a/applications/luci-app-ahcp/luasrc/view/ahcp_status.htm b/applications/luci-app-ahcp/luasrc/view/ahcp_status.htm
new file mode 100644
index 000000000..88796cb1c
--- /dev/null
+++ b/applications/luci-app-ahcp/luasrc/view/ahcp_status.htm
@@ -0,0 +1,53 @@
+<script type="text/javascript">//<![CDATA[
+ XHR.poll(5, '<%=luci.dispatcher.build_url("admin", "network", "ahcpd", "status")%>', null,
+ function(x, st)
+ {
+ var tb = document.getElementById('ahcpd_status_table');
+ var tx = document.getElementById('ahcpd_status_text');
+ if (st && tb && tx)
+ {
+ /* clear all rows */
+ while( tb.rows.length > 1 )
+ tb.deleteRow(1);
+
+ for( var i = 0; i < st.leases.length; i++ )
+ {
+ var tr = tb.insertRow(-1);
+ tr.className = 'cbi-section-table-row cbi-rowstyle-' + ((i % 2) + 1);
+
+ tr.insertCell(-1).innerHTML = st.leases[i].addr;
+ tr.insertCell(-1).innerHTML = String.format('%t', st.leases[i].age);
+ }
+
+ if( tb.rows.length == 1 )
+ {
+ var tr = tb.insertRow(-1);
+ tr.className = 'cbi-section-table-row';
+
+ var td = tr.insertCell(-1);
+ td.colSpan = 2;
+ td.innerHTML = '<em><br /><%:There are no active leases.%></em>';
+ }
+
+ if( st.uid == '00:00:00:00:00:00:00:00' )
+ tx.innerHTML = '<%:The AHCP Service is not running.%>';
+ else
+ tx.innerHTML = String.format('<%:The AHCP Service is running with ID %s.%>', st.uid);
+ }
+ }
+ );
+//]]></script>
+
+<fieldset class="cbi-section">
+ <legend><%:Active AHCP Leases%></legend>
+ <p id="ahcpd_status_text"></p>
+ <table class="cbi-section-table" id="ahcpd_status_table">
+ <tr class="cbi-section-table-titles">
+ <th class="cbi-section-table-cell"><%:Address%></th>
+ <th class="cbi-section-table-cell"><%:Age%></th>
+ </tr>
+ <tr class="cbi-section-table-row">
+ <td colspan="5"><em><br /><%:Collecting data...%></em></td>
+ </tr>
+ </table>
+</fieldset>