summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-advanced-reboot
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2019-08-17 04:29:01 -0700
committerStan Grishin <stangri@melmac.net>2019-08-17 04:29:01 -0700
commit0d0a8b882d1715dc6d31e86956556f6cf66a7845 (patch)
treea7b6b1def346f45e13e766d48fa2180072fc3abc /applications/luci-app-advanced-reboot
parentf3bcb918bf60ef9f3e8fff0a98ca570bfca26888 (diff)
luci-app-advanced-reboot: support for Linksys EA8300
Signed-off-by: Stan Grishin <stangri@melmac.net>
Diffstat (limited to 'applications/luci-app-advanced-reboot')
-rw-r--r--applications/luci-app-advanced-reboot/Makefile2
-rw-r--r--applications/luci-app-advanced-reboot/README.md5
-rw-r--r--applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua1
3 files changed, 6 insertions, 2 deletions
diff --git a/applications/luci-app-advanced-reboot/Makefile b/applications/luci-app-advanced-reboot/Makefile
index 2a7df3bd1..5381059da 100644
--- a/applications/luci-app-advanced-reboot/Makefile
+++ b/applications/luci-app-advanced-reboot/Makefile
@@ -13,7 +13,7 @@ LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot
LUCI_DEPENDS:=+luci-mod-admin-full
LUCI_PKGARCH:=all
-PKG_RELEASE:=40
+PKG_RELEASE:=41
include ../../luci.mk
diff --git a/applications/luci-app-advanced-reboot/README.md b/applications/luci-app-advanced-reboot/README.md
index 781a1c7f7..61e43637d 100644
--- a/applications/luci-app-advanced-reboot/README.md
+++ b/applications/luci-app-advanced-reboot/README.md
@@ -12,6 +12,7 @@ Currently supported dual-partition devices include:
- Linksys E4200v2
- Linksys EA4500
- Linksys EA6350v3
+- Linksys EA8300
- Linksys EA8500
- Linksys WRT1200AC
- Linksys WRT1900AC
@@ -36,6 +37,8 @@ opkg update
opkg install luci-app-advanced-reboot
```
+If the ```luci-app-advanced-reboot``` package is not found in the official feed/repo for your version of OpenWrt/LEDE Project, you will need to [add a custom repo to your router](https://github.com/stangri/openwrt_packages/blob/master/README.md#on-your-router) first.
+
## Notes/Known Issues
- When you reboot to a different partition, your current settings (WiFi SSID/password, etc.) will not apply to a different partition. Different partitions might have completely different settings and even firmware.
@@ -44,4 +47,4 @@ opkg install luci-app-advanced-reboot
## Thanks
-I'd like to thank everyone who helped create, test and troubleshoot this package. Without help from [@hnyman](https://github.com/hnyman), [@jpstyves](https://github.com/jpstyves), [@imi2003](https://github.com/imi2003) and many contributions from [@slh](https://github.com/pkgadd) it wouldn't have been possible.
+I'd like to thank everyone who helped create, test and troubleshoot this package. Without help from [@hnyman](https://github.com/hnyman), [@jpstyves](https://github.com/jpstyves), [@imi2003](https://github.com/imi2003), [@jeffsf](https://github.com/jeffsf) and many contributions from [@slh](https://github.com/pkgadd) it wouldn't have been possible.
diff --git a/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua b/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
index f40eac50c..e1f6daac1 100644
--- a/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
+++ b/applications/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
@@ -8,6 +8,7 @@ devices = {
{"Linksys EA3500", "linksys-audi", "mtd3", "mtd5", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
{"Linksys E4200v2/EA4500", "linksys-viper", "mtd3", "mtd5", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
{"Linksys EA6350v3", "linksys-ea6350v3", "mtd10", "mtd12", 192, "boot_part", 1, 2},
+ {"Linksys EA8300", "linksys-ea8300", "mtd10", "mtd12", 192, "boot_part", 1, 2},
{"Linksys EA8500", "ea8500", "mtd13", "mtd15", 32, "boot_part", 1, 2},
-- {"Linksys EA9500", "linksys-panamera", "mtd3", "mtd6", 28, "boot_part", 1, 2},
{"Linksys WRT1200AC", "linksys-caiman", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},