summaryrefslogtreecommitdiffhomepage
path: root/applications/luci-app-adblock
diff options
context:
space:
mode:
authordibdot <dev@brenken.org>2018-01-31 20:29:05 +0100
committerGitHub <noreply@github.com>2018-01-31 20:29:05 +0100
commit518ac523d1b0609c8fff7d2be05e239eebdb3006 (patch)
treec349523c437a5b833b2005f3effb57e052ddd744 /applications/luci-app-adblock
parent47d1eaaf306d55afeed3f4a398c8e46b00d4a9be (diff)
parent47e0990eac855f09d479f8d1f5b4fe19709a25de (diff)
Merge pull request #1614 from dibdot/adblock
luci-app-adblock: sync with adblock 3.5.0
Diffstat (limited to 'applications/luci-app-adblock')
-rw-r--r--applications/luci-app-adblock/Makefile2
-rw-r--r--applications/luci-app-adblock/luasrc/controller/adblock.lua4
-rw-r--r--applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua56
-rw-r--r--applications/luci-app-adblock/luasrc/view/adblock/query.htm2
-rw-r--r--applications/luci-app-adblock/luasrc/view/adblock/runtime.htm2
5 files changed, 37 insertions, 29 deletions
diff --git a/applications/luci-app-adblock/Makefile b/applications/luci-app-adblock/Makefile
index ae1eba251..2de2ed862 100644
--- a/applications/luci-app-adblock/Makefile
+++ b/applications/luci-app-adblock/Makefile
@@ -9,4 +9,4 @@ LUCI_PKGARCH:=all
include ../../luci.mk
-# call BuildPackage - OpenWrt buildroot signature \ No newline at end of file
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-adblock/luasrc/controller/adblock.lua b/applications/luci-app-adblock/luasrc/controller/adblock.lua
index 0cfbb5f7f..d4368e789 100644
--- a/applications/luci-app-adblock/luasrc/controller/adblock.lua
+++ b/applications/luci-app-adblock/luasrc/controller/adblock.lua
@@ -27,7 +27,7 @@ function logread()
local logfile
if nixio.fs.access("/var/log/messages") then
- logfile = util.trim(util.exec("cat /var/log/messages | grep -F 'adblock-'"))
+ logfile = util.trim(util.exec("grep -F 'adblock-' /var/log/messages"))
else
logfile = util.trim(util.exec("logread -e 'adblock-'"))
end
@@ -35,7 +35,7 @@ function logread()
end
function queryData(domain)
- if domain and domain:match("^[a-zA-Z0-9%-%._]+$") then
+ if domain then
luci.http.prepare_content("text/plain")
local cmd = "/etc/init.d/adblock query %q 2>&1"
local util = io.popen(cmd % domain)
diff --git a/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua b/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
index 476d8ece6..67d593c4d 100644
--- a/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
+++ b/applications/luci-app-adblock/luasrc/model/cbi/adblock/overview_tab.lua
@@ -231,43 +231,51 @@ e6:depends("adb_backup", 1)
e6.default = e6.disabled
e6.rmempty = true
-e7 = e:option(Flag, "adb_whitelist_mode", translate("Whitelist Mode"),
- translate("Block access to all domains except those explicitly listed in the whitelist file."))
-e7.default = e7.disabled
-e7.rmempty = true
-
-e8 = e:option(Flag, "adb_dnsflush", translate("Flush DNS Cache"),
- translate("Flush DNS Cache after adblock processing."))
+e7 = e:option(Value, "adb_maxqueue", translate("Max. Download Queue"),
+ translate("Size of the download queue to handle downloads & list processing in parallel (default '4').<br />")
+ .. translate("For further performance improvements you can raise this value, e.g. '8' or '16' should be safe."))
+e7.default = 4
+e7.datatype = "range(1,32)"
+e7.rmempty = false
+
+e8 = e:option(Flag, "adb_jail", translate("'Jail' Blocklist Creation"),
+ translate("Builds an additional 'Jail' list (/tmp/adb_list.jail) to block access to all domains except those listed in the whitelist file.<br />")
+ .. translate("You can use this restrictive blocklist manually e.g. for guest wifi or kidsafe configurations."))
e8.default = e8.disabled
e8.rmempty = true
-e9 = e:option(Flag, "adb_notify", translate("Email Notification"),
- translate("Send notification emails in case of a processing error or if domain count is &le; 0.<br />")
- .. translate("Please note: this needs additional 'mstmp' installation and setup (see readme)."))
+e9 = e:option(Flag, "adb_dnsflush", translate("Flush DNS Cache"),
+ translate("Flush DNS Cache after adblock processing."))
e9.default = e9.disabled
e9.rmempty = true
-e10 = e:option(Value, "adb_notifycnt", translate("Email Notification Count"),
+e10 = e:option(Flag, "adb_notify", translate("Email Notification"),
+ translate("Send notification emails in case of a processing error or if domain count is &le; 0.<br />")
+ .. translate("Please note: this needs additional 'mstmp' package installation and setup."))
+e10.default = e10.disabled
+e10.rmempty = true
+
+e11 = e:option(Value, "adb_notifycnt", translate("Email Notification Count"),
translate("Raise the minimum email notification count, to get emails if the overall count is less or equal to the given limit (default 0),<br />")
.. translate("e.g. to receive an email notification with every adblock update set this value to 150000."))
-e10.default = 0
-e10.datatype = "min(0)"
-e10.optional = true
+e11.default = 0
+e11.datatype = "min(0)"
+e11.optional = true
-e11 = e:option(Value, "adb_dnsdir", translate("DNS Directory"),
+e12 = e:option(Value, "adb_dnsdir", translate("DNS Directory"),
translate("Target directory for the generated blocklist 'adb_list.overall'."))
-e11.datatype = "directory"
-e11.optional = true
+e12.datatype = "directory"
+e12.optional = true
-e12 = e:option(Value, "adb_whitelist", translate("Whitelist File"),
+e13 = e:option(Value, "adb_whitelist", translate("Whitelist File"),
translate("Full path to the whitelist file."))
-e12.datatype = "file"
-e12.default = "/etc/adblock/adblock.whitelist"
-e12.optional = true
+e13.datatype = "file"
+e13.default = "/etc/adblock/adblock.whitelist"
+e13.optional = true
-e13 = e:option(Value, "adb_triggerdelay", translate("Trigger Delay"),
+e14 = e:option(Value, "adb_triggerdelay", translate("Trigger Delay"),
translate("Additional trigger delay in seconds before adblock processing begins."))
-e13.datatype = "range(1,60)"
-e13.optional = true
+e14.datatype = "range(1,60)"
+e14.optional = true
return m
diff --git a/applications/luci-app-adblock/luasrc/view/adblock/query.htm b/applications/luci-app-adblock/luasrc/view/adblock/query.htm
index ce706e40a..8bbc92664 100644
--- a/applications/luci-app-adblock/luasrc/view/adblock/query.htm
+++ b/applications/luci-app-adblock/luasrc/view/adblock/query.htm
@@ -49,7 +49,7 @@ This is free software, licensed under the Apache License, Version 2.0
<fieldset class="cbi-section">
<div class="cbi-section-descr"><%:This form allows you to query active block lists for certain domains, e.g. for whitelisting.%></div>
<div style="width:33%; float:left;">
- <input style="margin: 5px 0" type="text" value="www.lede-project.org" name="input" />
+ <input style="margin: 5px 0" type="text" value="google.com" name="input" />
<input type="button" value="<%:Query%>" class="cbi-button cbi-button-apply" onclick="update_status(this.form.input)" />
</div>
<br style="clear:both" />
diff --git a/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm b/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
index e7827b5c3..c01d9a5c0 100644
--- a/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
+++ b/applications/luci-app-adblock/luasrc/view/adblock/runtime.htm
@@ -5,6 +5,6 @@ This is free software, licensed under the Apache License, Version 2.0
<%+cbi/valueheader%>
-<input name="runtime" id="runtime" type="text" class="cbi-input-text" style="outline:none;border:none;box-shadow:none;background:transparent;color:#0069d6;font-weight:bold;line-height:30px;height:30px;" value="<%=self:cfgvalue(section)%>" disabled="disabled" />
+<input name="runtime" id="runtime" type="text" class="cbi-input-text" style="outline:none;border:none;box-shadow:none;background:transparent;color:#0069d6;font-weight:bold;line-height:30px;height:30px;width:20em;" value="<%=self:cfgvalue(section)%>" disabled="disabled" />
<%+cbi/valuefooter%>