summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-05-14 21:10:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-05-14 21:10:40 +0000
commit4fbecc4874340a2e844a2deecdc49ea2cfa1f620 (patch)
treef2149a323620479f581601ccddb76ae8d67ae2af /Makefile
parent6948b6bc70456ab137463dc1b8520e6abc9480e3 (diff)
build: add "po" target to Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a45d39e89..4abb358b2 100644
--- a/Makefile
+++ b/Makefile
@@ -66,6 +66,12 @@ uvldocs: hostenv
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
"build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+po:
+ for L in $${LANGUAGE:-$$(find i18n/ -path 'i18n/*/luasrc/i18n/*' -name 'default.*.lua' | \
+ sed -e 's!.*/default\.\(.*\)\.lua!\1!')}; do \
+ build/i18n-lua2po.pl . $(realpath host)/po $$L; \
+ done
+
run:
# make run is deprecated #
# Please use: #