summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-06-20 07:20:56 +0000
committerSteven Barth <steven@midlink.org>2009-06-20 07:20:56 +0000
commita060a9e135ce0bf94496935aea5a4981ca0da750 (patch)
tree0fa2894746474645cc038c94cc386c874c9f814b /Makefile
parent341f757255caa08ee2922a3f32a00849e306f23c (diff)
Fix SDK build process
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index d082a9807..13438848e 100644
--- a/Makefile
+++ b/Makefile
@@ -50,15 +50,8 @@ hostenv: host ucidefaults
ucidefaults:
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"
-runboa: hostenv
- libs/sgi-webuci/host/buildconfig.sh $(realpath host) > host/etc/boa/boa.conf
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/boa) -c $(realpath host/etc/boa) -d"
-
runhttpd: hostenv
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/lucittpd) $(realpath host)/usr/lib/lucittpd/plugins"
-
-runluci: luahost
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath libs/httpd/host/runluci) $(realpath host) $(HTDOCS)"
+ build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua build/lucid.lua"
runlua: hostenv
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua -i build/setup.lua"