summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-07-09 15:05:02 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-07-09 15:05:02 +0000
commitf2b1b113dea96215b42727c2c00c757d2809a837 (patch)
tree0267fc3de59ad67274cf68212480f752c391d1d2 /Makefile
parentd9d3c714351b82cfd387fc6f83d89591909312a2 (diff)
build: embed lmo in the build process
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 13438848e..775820cb1 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,7 @@ all: build
build: gccbuild luabuild
gccbuild:
+ make -C libs/lmo CC="cc" CFLAGS="" LDFLAGS="" host-install
for i in $(MODULES); do \
make -C$$i compile || { \
echo "*** Compilation of $$i failed!"; \
@@ -27,7 +28,7 @@ i18nbuild:
./build/i18n-po2lua.pl ./po host/lua-po
clean:
- rm -rf docs
+ make -C libs/lmo host-clean
for i in $(MODULES); do make -C$$i clean; done