summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-09-24 22:02:11 +0000
committerSteven Barth <steven@midlink.org>2008-09-24 22:02:11 +0000
commit402485bfcc6d1246c23dfee03eab753b379b684c (patch)
treeab232a128398b81330b6c5c6c35a27170d7ffb73 /Makefile
parent9dc504b285a80c381d612cb8dccc58ff5f39368e (diff)
some BSD compatibility stuff
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 6c7d399e76..e673b22dc2 100644
--- a/Makefile
+++ b/Makefile
@@ -30,8 +30,8 @@ luahost: luabuild hostcopy
hostcopy:
mkdir -p host/tmp
- for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
- for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
+ for i in $(MODULES); do cp -pR $$i/dist/* host/ 2>/dev/null || true; done
+ for i in $(MODULES); do cp -pR $$i/hostfiles/* host/ 2>/dev/null || true; done
rm -f host/luci
ln -s .$(LUCI_MODULEDIR) host/luci
rm -rf /tmp/luci-* || true