diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2009-06-11 11:10:01 +0000 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2009-06-11 11:10:01 +0000 |
commit | 90ce9746c230510f690407b7ccc1330bdca48bbd (patch) | |
tree | 997a256d431ebd3e1adf1ee7bed87b4ab00ab50b /Makefile | |
parent | 63160370ee1d21f59360bffb03c7c871da9a2e09 (diff) |
build: make building more strict, abort on errors in gccbuild phase
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -12,7 +12,12 @@ all: build build: gccbuild luabuild gccbuild: - for i in $(MODULES); do make -C$$i compile; done + for i in $(MODULES); do \ + make -C$$i compile || { \ + echo "*** Compilation of $$i failed!"; \ + exit 1; \ + }; \ + done luabuild: i18nbuild for i in $(MODULES); do HOST=$(realpath host) make -C$$i luabuild; done |