summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-03-26 20:55:14 +0000
committerSteven Barth <steven@midlink.org>2008-03-26 20:55:14 +0000
commit68d142e79287e9b5e9f980f37b546070a38fc478 (patch)
tree8d165ffd6e50795b7f140efb0e7ed7f103d2e47d /Makefile
parent5f9910566de7165f4bb0ee62bc3ace53c708a94e (diff)
* CBI update
* Added some configuration pages * Introduced contact site * Introduced luci UCI config file
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index e2a74c088..bc765c968 100644
--- a/Makefile
+++ b/Makefile
@@ -1,14 +1,14 @@
LUAC = luac
LUAC_OPTIONS = -s
-FILES = ffluci/config.lua
+FILES =
-CFILES = ffluci/util.lua ffluci/http.lua \
-ffluci/fs.lua ffluci/i18n.lua ffluci/model/uci.lua \
+CFILES = ffluci/util.lua ffluci/http.lua ffluci/fs.lua \
+ffluci/model/uci.lua ffluci/config.lua ffluci/i18n.lua \
ffluci/template.lua ffluci/cbi.lua ffluci/dispatcher.lua \
ffluci/menu.lua ffluci/init.lua ffluci/sys.lua
-DIRECTORIES = dist/ffluci/model dist/ffluci/controller dist/ffluci/i18n dist/ffluci/view
+DIRECTORIES = dist/ffluci/model/cbi dist/ffluci/controller dist/ffluci/i18n dist/ffluci/view
INFILES = $(CFILES:%=src/%)
OUTFILE = ffluci/init.lua
@@ -28,6 +28,7 @@ dist:
cp src/ffluci/controller/* dist/ffluci/controller/ -R
cp src/ffluci/i18n/* dist/ffluci/i18n/
cp src/ffluci/view/* dist/ffluci/view/ -R
+ cp src/ffluci/model/cbi/* dist/ffluci/model/cbi/ -R
examples:
cp examples/* dist/ -R