summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-05 19:21:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-05 19:21:07 +0000
commit0b547cf6b450113b8bb6467c9a17da882896d489 (patch)
treedf905248d7669ad46ec51e2ff85f1bf14200f65a /Makefile
parenta4b9126070b19ee92d1387f0cf0f57f17fd85534 (diff)
build: only consider directories containing a Makefile, fixes compilation crashes if a file or empty directory exists in modules/, applications/ etc.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 21c88b2db..efccd79d0 100644
--- a/Makefile
+++ b/Makefile
@@ -3,6 +3,8 @@ include build/config.mk
MODULES = contrib/* applications/* libs/* modules/* themes/* i18n/*
OS:=$(shell uname)
+MODULES:=$(foreach item,$(wildcard $(MODULES)),$(if $(realpath $(wildcard $(item)/Makefile)),$(item)))
+
export OS
.PHONY: all build gccbuild luabuild clean host gcchost luahost hostcopy hostclean