summaryrefslogtreecommitdiffhomepage
path: root/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-28 16:03:54 +0000
committerSteven Barth <steven@midlink.org>2008-06-28 16:03:54 +0000
commit00aceaf624d8e5da2a8f3df161d52599aae2ac41 (patch)
treec18d8c411f8d4a02762a478348fd8a86b4f56f5a /Makefile
parent7f56bf947599b20e2cf50018e160e602d5516e5f (diff)
* libs/web: Switched from HTTP-Basic-Auth to Session-Auth
* Updated Makefiles for better testing environment integration * Fixed libs/sgi-luci
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8ce59c268..8ac0ac664 100644
--- a/Makefile
+++ b/Makefile
@@ -35,10 +35,14 @@ hostcopy:
ln -s .$(LUCI_MODULEDIR) host/luci
runboa: host
+ export LUA_PATH="`pwd`/host$(LUCI_MODULEDIR);;"
+ export LUA_CPATH="`pwd`/host$(LUCI_LIBRARYDIR);;"
libs/sgi-webuci/host/buildconfig.sh `pwd`/host > host/etc/boa/boa.conf
./host/usr/bin/boa -c ./host/etc/boa -d
runluci: luahost
+ export LUA_PATH="`pwd`/host$(LUCI_MODULEDIR);;"
+ export LUA_CPATH="`pwd`/host$(LUCI_LIBRARYDIR);;"
libs/httpd/host/runluci host$(HTDOCS)
hostclean: clean