summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorLukas Voegl <lvoegl@tdt.de>2023-11-03 14:52:19 +0100
committerLukas Voegl <lvoegl@tdt.de>2023-11-10 15:48:13 +0100
commitb783e4c88cb63508a9d9a869b7ed967edb9f07ed (patch)
tree03dbe220da4f2a0938cd4e6cd63467c053ab97da
parent6c0f603f027b1ba615c7c8cb851625f50e25ef22 (diff)
luci-app-ipsec: rename to luci-app-strongswan-swanctl
Signed-off-by: Lukas Voegl <lvoegl@tdt.de>
-rw-r--r--applications/luci-app-strongswan-ipsec/Makefile15
-rw-r--r--applications/luci-app-strongswan-ipsec/root/usr/share/luci/menu.d/luci-app-strongswan-ipsec.json15
-rw-r--r--applications/luci-app-strongswan-ipsec/root/usr/share/rpcd/acl.d/luci-app-strongswan-ipsec.json11
-rw-r--r--applications/luci-app-strongswan-swanctl/Makefile17
-rw-r--r--applications/luci-app-strongswan-swanctl/htdocs/luci-static/resources/view/strongswan-swanctl/swanctl.js (renamed from applications/luci-app-strongswan-ipsec/htdocs/luci-static/resources/view/ipsec.js)10
-rw-r--r--applications/luci-app-strongswan-swanctl/root/etc/config/ipsec (renamed from applications/luci-app-strongswan-ipsec/root/etc/config/ipsec)0
-rw-r--r--applications/luci-app-strongswan-swanctl/root/usr/share/luci/menu.d/luci-app-strongswan-swanctl.json15
-rw-r--r--applications/luci-app-strongswan-swanctl/root/usr/share/rpcd/acl.d/luci-app-strongswan-swanctl.json11
8 files changed, 48 insertions, 46 deletions
diff --git a/applications/luci-app-strongswan-ipsec/Makefile b/applications/luci-app-strongswan-ipsec/Makefile
deleted file mode 100644
index 5dbbe2124f..0000000000
--- a/applications/luci-app-strongswan-ipsec/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 2021 Nicholas Smith (nicholas@nbembedded.com)
-# This is free software, licensed under the GNU General Public License v2.
-
-include $(TOPDIR)/rules.mk
-
-PKG_LICENSE:=GPL-2.0-or-later
-PKG_MAINTAINER:=Nicholas Smith <nicholas@nbembedded.com>
-
-LUCI_TITLE:=LuCI support for IPSec via Strongswan
-LUCI_DESCRIPTION:=Allows configuration of Strongswan IPSec settings
-LUCI_DEPENDS:=+strongswan-ipsec
-
-include ../../luci.mk
-
-# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-strongswan-ipsec/root/usr/share/luci/menu.d/luci-app-strongswan-ipsec.json b/applications/luci-app-strongswan-ipsec/root/usr/share/luci/menu.d/luci-app-strongswan-ipsec.json
deleted file mode 100644
index 8fc3e9c8c2..0000000000
--- a/applications/luci-app-strongswan-ipsec/root/usr/share/luci/menu.d/luci-app-strongswan-ipsec.json
+++ /dev/null
@@ -1,15 +0,0 @@
-{
- "admin/vpn/strongswan-ipsec": {
- "title": "Strongswan IPSec",
- "order": 90,
- "action": {
- "type": "view",
- "path": "strongswan-ipsec"
- },
- "depends": {
- "acl": [
- "luci-app-strongswan-ipsec"
- ]
- }
- }
-}
diff --git a/applications/luci-app-strongswan-ipsec/root/usr/share/rpcd/acl.d/luci-app-strongswan-ipsec.json b/applications/luci-app-strongswan-ipsec/root/usr/share/rpcd/acl.d/luci-app-strongswan-ipsec.json
deleted file mode 100644
index 3b940b8281..0000000000
--- a/applications/luci-app-strongswan-ipsec/root/usr/share/rpcd/acl.d/luci-app-strongswan-ipsec.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "luci-app-strongswan-ipsec": {
- "description": "Grant access to luci-app-strongswan-ipsec",
- "read": {
- "uci": [ "ipsec" ]
- },
- "write": {
- "uci": [ "ipsec" ]
- }
- }
-}
diff --git a/applications/luci-app-strongswan-swanctl/Makefile b/applications/luci-app-strongswan-swanctl/Makefile
new file mode 100644
index 0000000000..0e847c7bf5
--- /dev/null
+++ b/applications/luci-app-strongswan-swanctl/Makefile
@@ -0,0 +1,17 @@
+# Copyright 2021 Nicholas Smith (nicholas@nbembedded.com)
+# Copyright (C) 2023 TDT AG <development@tdt.de>
+#
+# This is free software, licensed under the GNU General Public License v2.
+
+include $(TOPDIR)/rules.mk
+
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_MAINTAINER:=Nicholas Smith <nicholas@nbembedded.com>, Lukas Voegl <lvoegl@tdt.de>
+
+LUCI_TITLE:=LuCI support for strongSwan via swanctl
+LUCI_DESCRIPTION:=Configuration for strongSwan based on swanctl
+LUCI_DEPENDS:=+strongswan-swanctl
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-strongswan-ipsec/htdocs/luci-static/resources/view/ipsec.js b/applications/luci-app-strongswan-swanctl/htdocs/luci-static/resources/view/strongswan-swanctl/swanctl.js
index 53acf71e8e..d2e7103afa 100644
--- a/applications/luci-app-strongswan-ipsec/htdocs/luci-static/resources/view/ipsec.js
+++ b/applications/luci-app-strongswan-swanctl/htdocs/luci-static/resources/view/strongswan-swanctl/swanctl.js
@@ -8,11 +8,11 @@ return view.extend({
var m, s, o;
m = new form.Map('ipsec',
- _('IPsec Configuration'),
- _("Configure IPsec for secure VPN connections."));
+ _('strongSwan Configuration'),
+ _("Configure strongSwan for secure VPN connections."));
- // IPsec General Settings
- s = m.section(form.TypedSection, 'ipsec', _('IPsec General Settings'));
+ // strongSwan General Settings
+ s = m.section(form.TypedSection, 'ipsec', _('strongSwan General Settings'));
s.anonymous = true;
o = s.option(widgets.ZoneSelect, 'zone', _('Zone'), _('Firewall zone that has to match the defined firewall zone'));
@@ -87,7 +87,7 @@ return view.extend({
o = s.option(form.Value, 'authentication_method', _('Authentication Method'), _('IKE authentication (phase 1)'));
o.datatype = 'string';
- s = m.section(form.TypedSection, 'ipsec', _('IPsec General Settings'));
+ s = m.section(form.TypedSection, 'ipsec', _('strongSwan General Settings'));
s.anonymous = true;
o = s.option(form.ListValue, 'encryption_algorithm', _('Encryption Algorithm'), _('Encryption method (aes128, aes192, aes256, 3des)'));
diff --git a/applications/luci-app-strongswan-ipsec/root/etc/config/ipsec b/applications/luci-app-strongswan-swanctl/root/etc/config/ipsec
index 20ef4dd84d..20ef4dd84d 100644
--- a/applications/luci-app-strongswan-ipsec/root/etc/config/ipsec
+++ b/applications/luci-app-strongswan-swanctl/root/etc/config/ipsec
diff --git a/applications/luci-app-strongswan-swanctl/root/usr/share/luci/menu.d/luci-app-strongswan-swanctl.json b/applications/luci-app-strongswan-swanctl/root/usr/share/luci/menu.d/luci-app-strongswan-swanctl.json
new file mode 100644
index 0000000000..2f0c5c5d1f
--- /dev/null
+++ b/applications/luci-app-strongswan-swanctl/root/usr/share/luci/menu.d/luci-app-strongswan-swanctl.json
@@ -0,0 +1,15 @@
+{
+ "admin/vpn/strongswan-swanctl": {
+ "title": "strongSwan IPsec",
+ "order": 90,
+ "action": {
+ "type": "view",
+ "path": "strongswan-swanctl/swanctl"
+ },
+ "depends": {
+ "acl": [
+ "luci-app-strongswan-swanctl"
+ ]
+ }
+ }
+}
diff --git a/applications/luci-app-strongswan-swanctl/root/usr/share/rpcd/acl.d/luci-app-strongswan-swanctl.json b/applications/luci-app-strongswan-swanctl/root/usr/share/rpcd/acl.d/luci-app-strongswan-swanctl.json
new file mode 100644
index 0000000000..4f022c9463
--- /dev/null
+++ b/applications/luci-app-strongswan-swanctl/root/usr/share/rpcd/acl.d/luci-app-strongswan-swanctl.json
@@ -0,0 +1,11 @@
+{
+ "luci-app-strongswan-swanctl": {
+ "description": "Grant access to luci-app-strongswan-swanctl",
+ "read": {
+ "uci": [ "ipsec" ]
+ },
+ "write": {
+ "uci": [ "ipsec" ]
+ }
+ }
+}