summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.net>2020-07-29 09:41:12 +0000
committerStan Grishin <stangri@melmac.net>2020-07-29 09:41:12 +0000
commit9c2bc71d2e8389e4d05f20bdcbb4dc3d8b7eb779 (patch)
treeccaf7d3986e6ce17bfe6df9d01e95e091cd66fef
parent1c92d9f706de9a411c549bac60a9a3ba67533f4e (diff)
luci-app-https-dns-proxy: add OpenDNS servers
Signed-off-by: Stan Grishin <stangri@melmac.net>
-rw-r--r--applications/luci-app-https-dns-proxy/Makefile2
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua8
-rw-r--r--applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua8
-rw-r--r--applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot8
4 files changed, 25 insertions, 1 deletions
diff --git a/applications/luci-app-https-dns-proxy/Makefile b/applications/luci-app-https-dns-proxy/Makefile
index b18e019aa..097f93b64 100644
--- a/applications/luci-app-https-dns-proxy/Makefile
+++ b/applications/luci-app-https-dns-proxy/Makefile
@@ -10,7 +10,7 @@ LUCI_TITLE:=DNS Over HTTPS Proxy Web UI
LUCI_DESCRIPTION:=Provides Web UI for DNS Over HTTPS Proxy
LUCI_DEPENDS:=+luci-compat +luci-mod-admin-full +https-dns-proxy
LUCI_PKGARCH:=all
-PKG_RELEASE:=9
+PKG_RELEASE:=10
include ../../luci.mk
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua
new file mode 100644
index 000000000..b3eff188a
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua
@@ -0,0 +1,8 @@
+return {
+ name = "OpenDNS",
+ label = _("OpenDNS"),
+ resolver_url = "https://doh.opendns.com/dns-query",
+ bootstrap_dns = "208.67.222.222,208.67.220.220",
+ help_link = "https://support.opendns.com/hc/en-us/articles/360038086532-Using-DNS-over-HTTPS-DoH-with-OpenDNS",
+ help_link_text = "OpenDNS"
+}
diff --git a/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua
new file mode 100644
index 000000000..12cc89a96
--- /dev/null
+++ b/applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua
@@ -0,0 +1,8 @@
+return {
+ name = "OpenDNS-FamilyShield",
+ label = _("OpenDNS (Family Shield)"),
+ resolver_url = "https://doh.familyshield.opendns.com/dns-query",
+ bootstrap_dns = "208.67.222.123,208.67.220.123",
+ help_link = "https://support.opendns.com/hc/en-us/articles/360038086532-Using-DNS-over-HTTPS-DoH-with-OpenDNS",
+ help_link_text = "OpenDNS"
+}
diff --git a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
index 00931c200..7b680cd15 100644
--- a/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
+++ b/applications/luci-app-https-dns-proxy/po/templates/https-dns-proxy.pot
@@ -113,6 +113,14 @@ msgstr ""
msgid "ODVR (nic.cz)"
msgstr ""
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.doh.lua:3
+msgid "OpenDNS"
+msgstr ""
+
+#: applications/luci-app-https-dns-proxy/luasrc/https-dns-proxy/providers/com.opendns.familyshield.doh.lua:3
+msgid "OpenDNS (Family Shield)"
+msgstr ""
+
#: applications/luci-app-https-dns-proxy/luasrc/model/cbi/https-dns-proxy.lua:177
msgid "Proxy server"
msgstr ""