summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2023-09-26 22:54:37 +0000
committerStan Grishin <stangri@melmac.ca>2023-09-26 22:54:37 +0000
commit8d502df1b0951c415b236ccfd7a3b8ae104b765f (patch)
tree5ddfec731574708caa45e80c7b58d00b497b80dd
parent957a6313bd6371e5afae20573a43f5440948e66e (diff)
luci-app-adblock-fast: update to 1.0.0-3
Signed-off-by: Stan Grishin <stangri@melmac.ca>
-rw-r--r--applications/luci-app-adblock-fast/Makefile3
-rw-r--r--applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js5
-rw-r--r--applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js41
-rw-r--r--applications/luci-app-adblock-fast/po/templates/adblock-fast.pot152
4 files changed, 111 insertions, 90 deletions
diff --git a/applications/luci-app-adblock-fast/Makefile b/applications/luci-app-adblock-fast/Makefile
index b55ac6a1eb..32fef1678e 100644
--- a/applications/luci-app-adblock-fast/Makefile
+++ b/applications/luci-app-adblock-fast/Makefile
@@ -5,11 +5,12 @@ include $(TOPDIR)/rules.mk
PKG_LICENSE:=GPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.0.0-1
+PKG_VERSION:=1.0.0-3
LUCI_TITLE:=AdBlock-Fast Web UI
LUCI_DESCRIPTION:=Provides Web UI for adblock-fast service.
LUCI_DEPENDS:=+luci-base +adblock-fast +jsonfilter
+LUCI_PKGARCH:=all
include ../../luci.mk
diff --git a/applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js b/applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js
index 901d3d9f26..fa1f98e3cd 100644
--- a/applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js
+++ b/applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js
@@ -270,11 +270,12 @@ var status = baseclass.extend({
),
errorDownloadingList: _("Failed to download %s"),
errorParsingConfigUpdate: _("Failed to parse Config Update file"),
- errorParsingList: _("Failed to parse"),
+ errorParsingList: _("Failed to parse %s"),
errorNoSSLSupport: _("No HTTPS/SSL support on device"),
errorCreatingDirectory: _(
"Failed to create output/cache/gzip file directory"
),
+ errorDetectingFileType: _("Failed to detect format %s"),
};
var errorsTitle = E(
"label",
@@ -287,7 +288,7 @@ var status = baseclass.extend({
errorTable[element.id].format(element.extra || " ") + "<br />";
});
text += _("Errors encountered, please check the %sREADME%s!").format(
- "<a href='" + pkg.URL + '" target="_blank">',
+ '<a href="' + pkg.URL + '" target="_blank">',
"</a><br />"
);
var errorsText = E("div", {}, text);
diff --git a/applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js b/applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js
index 92caf6b35d..ce9041e8f8 100644
--- a/applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js
+++ b/applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js
@@ -125,7 +125,7 @@ return view.extend({
if (reply.platform.unbound_installed) {
o.value("unbound.adb_list", _("unbound adblock list"));
}
- o.default = ("dnsmasq.servers", _("dnsmasq servers file"));
+ o.default = "dnsmasq.servers";
o = s1.taboption(
"tab_basic",
@@ -154,6 +154,23 @@ return view.extend({
)
);
o.value("*", _("AdBlock on all instances"));
+
+ // Object.values(L.uci.sections("dhcp", "dnsmasq")).forEach(function (
+ // val,
+ // index
+ // ) {
+ // const nameValueMap = new Map(Object.entries(val));
+ // so.value(
+ // nameValueMap.get(".name"),
+ // "%s (Name: %s, Domain: %s, Local: %s)".format(
+ // nameValueMap.get(".index"),
+ // nameValueMap.get(".name") || "noname",
+ // val.domain || "unset",
+ // val.local || "unset"
+ // )
+ // );
+ // });
+
var sections = uci.sections("dhcp", "dnsmasq");
sections.forEach((element) => {
var description;
@@ -182,7 +199,7 @@ return view.extend({
);
o.value("0", _("Let local devices use their own DNS servers if set"));
o.value("1", _("Force Router DNS server to all local devices"));
- o.default = ("1", _("Force Router DNS server to all local devices"));
+ o.default = "1";
o = s1.taboption(
"tab_basic",
@@ -194,7 +211,7 @@ return view.extend({
o.value("0", _("Suppress output"));
o.value("1", _("Some output"));
o.value("2", _("Verbose output"));
- o.default = ("2", _("Verbose output"));
+ o.default = "2";
if (reply.platform.leds.length) {
o = s1.taboption(
@@ -211,6 +228,7 @@ return view.extend({
o.value(element);
});
}
+
o = s1.taboption(
"tab_advanced",
form.ListValue,
@@ -220,7 +238,7 @@ return view.extend({
);
o.value("0", _("Disable"));
o.value("1", _("Enable"));
- o.default = ("0", _("Disable"));
+ o.default = "0";
o = s1.taboption(
"tab_advanced",
@@ -233,7 +251,7 @@ return view.extend({
o.value("1", _("Add IPv6 entries"));
o.depends("dns", "dnsmasq.addnhosts");
o.depends("dns", "dnsmasq.nftset");
- o.default = ("", _("Do not add IPv6 entries"));
+ o.default = "";
o.rmempty = true;
o.retain = true;
@@ -283,7 +301,7 @@ return view.extend({
);
o.value("0", _("Do not use simultaneous processing"));
o.value("1", _("Use simultaneous processing"));
- o.default = ("1", _("Use simultaneous processing"));
+ o.default = "1";
o = s1.taboption(
"tab_advanced",
@@ -296,7 +314,7 @@ return view.extend({
);
o.value("0", _("Do not store compressed cache"));
o.value("1", _("Store compressed cache"));
- o.default = ("0", _("Do not store compressed cache"));
+ o.default = "0";
o = s1.taboption(
"tab_advanced",
@@ -322,7 +340,7 @@ return view.extend({
);
o.value("0", _("Disable Debugging"));
o.value("1", _("Enable Debugging"));
- o.default = ("0", _("Disable Debugging"));
+ o.default = "0";
s2 = m.section(
form.NamedSection,
@@ -332,14 +350,15 @@ return view.extend({
);
o.addremove = true;
o.rmempty = true;
+
o = s2.option(
form.DynamicList,
"allowed_domain",
_("Allowed Domains"),
_("Individual domains to be allowed.")
);
-
o.addremove = true;
+
o = s2.option(
form.DynamicList,
"blocked_domain",
@@ -358,6 +377,7 @@ return view.extend({
s3.sortable = true;
s3.anonymous = true;
s3.addremove = true;
+
o = s3.option(form.DummyValue, "_size", "Size");
o.modalonly = false;
o.cfgvalue = function (section_id) {
@@ -370,13 +390,16 @@ return view.extend({
});
return _("Size: %s").format(ret);
};
+
o = s3.option(form.Flag, "enabled", _("Enable"));
o.editable = true;
o.default = "1";
+
o = s3.option(form.ListValue, "action", _("Action"));
o.value("allow", _("Allow"));
o.value("block", _("Block"));
o.default = "block";
+
o = s3.option(form.Value, "url", _("URL"));
o.optional = false;
diff --git a/applications/luci-app-adblock-fast/po/templates/adblock-fast.pot b/applications/luci-app-adblock-fast/po/templates/adblock-fast.pot
index 3a51e0a37f..93cbb0a062 100644
--- a/applications/luci-app-adblock-fast/po/templates/adblock-fast.pot
+++ b/applications/luci-app-adblock-fast/po/templates/adblock-fast.pot
@@ -9,7 +9,7 @@ msgstr ""
msgid "%s is not installed or not found"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:376
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:398
msgid "Action"
msgstr ""
@@ -21,7 +21,7 @@ msgstr ""
msgid "AdBlock Fast"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:168
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:185
msgid "AdBlock on %s only"
msgstr ""
@@ -29,11 +29,11 @@ msgstr ""
msgid "AdBlock on all instances"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:331
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:349
msgid "AdBlock-Fast - Allowed and Blocked Domains"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:354
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:373
msgid "AdBlock-Fast - Allowed and Blocked Lists URLs"
msgstr ""
@@ -45,11 +45,11 @@ msgstr ""
msgid "AdBlock-Fast - Status"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:233
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:251
msgid "Add IPv6 entries"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:230
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:248
msgid "Add IPv6 entries to block-list."
msgstr ""
@@ -57,20 +57,20 @@ msgstr ""
msgid "Advanced Configuration"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:377
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:399
msgid "Allow"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:338
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:357
msgid "Allowed Domains"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:294
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:312
msgid ""
"Attempt to create a compressed cache of block-list in the persistent memory."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:218
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:236
msgid "Automatic Config Update"
msgstr ""
@@ -78,11 +78,11 @@ msgstr ""
msgid "Basic Configuration"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:378
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:400
msgid "Block"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:346
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:365
msgid "Blocked Domains"
msgstr ""
@@ -106,15 +106,15 @@ msgstr ""
msgid "Config (%s) validation failure!"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:192
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:209
msgid "Controls system log and console output verbosity."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:267
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:285
msgid "Curl download retry"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:254
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:272
msgid "Curl maximum file size (in bytes)"
msgstr ""
@@ -126,23 +126,21 @@ msgstr ""
msgid "DNS resolution option, see the %sREADME%s for details."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:305
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:323
msgid "Directory for compressed cache file"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:307
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:325
msgid ""
"Directory for compressed cache file of block-list in the persistent memory."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:400
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:221
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:223
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:401
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:239
msgid "Disable"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:323
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:325
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:341
msgid "Disable Debugging"
msgstr ""
@@ -150,7 +148,7 @@ msgstr ""
msgid "Disabled"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:394
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:395
msgid "Disabling %s service"
msgstr ""
@@ -158,21 +156,19 @@ msgstr ""
msgid "Dnsmasq Config File URL"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:232
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:236
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:250
msgid "Do not add IPv6 entries"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:297
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:299
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:315
msgid "Do not store compressed cache"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:284
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:302
msgid "Do not use simultaneous processing"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:244
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:262
msgid "Download time-out (in seconds)"
msgstr ""
@@ -180,22 +176,22 @@ msgstr ""
msgid "Downloading lists"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:381
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:222
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:373
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:382
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:240
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:394
msgid "Enable"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:320
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:324
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:338
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:342
msgid "Enable Debugging"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:321
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:339
msgid "Enables debug output to /tmp/adblock-fast.log."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:375
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:376
msgid "Enabling %s service"
msgstr ""
@@ -203,7 +199,7 @@ msgstr ""
msgid "Error"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:289
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:290
msgid "Errors encountered, please check the %sREADME%s!"
msgstr ""
@@ -235,6 +231,10 @@ msgstr ""
msgid "Failed to create output/cache/gzip file directory"
msgstr ""
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:278
+msgid "Failed to detect format %s"
+msgstr ""
+
#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:271
msgid "Failed to download %s"
msgstr ""
@@ -260,7 +260,7 @@ msgid "Failed to optimize data file"
msgstr ""
#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:273
-msgid "Failed to parse"
+msgid "Failed to parse %s"
msgstr ""
#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:272
@@ -299,7 +299,7 @@ msgstr ""
msgid "Force DNS ports:"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:343
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:344
msgid "Force Re-Download"
msgstr ""
@@ -307,20 +307,19 @@ msgstr ""
msgid "Force Reloading"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:180
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:197
msgid "Force Router DNS"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:184
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:185
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:201
msgid "Force Router DNS server to all local devices"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:337
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:338
msgid "Force re-downloading %s block lists"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:181
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:198
msgid "Forces Router DNS use on local devices, also known as DNS Hijacking."
msgstr ""
@@ -328,45 +327,45 @@ msgstr ""
msgid "Grant UCI and file access for luci-app-adblock-fast"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:229
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:247
msgid "IPv6 Support"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:256
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:274
msgid ""
"If curl is installed and detected, it would not download files bigger than "
"this."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:269
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:287
msgid ""
"If curl is installed and detected, it would retry download this many times "
"on timeout/fail."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:339
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:358
msgid "Individual domains to be allowed."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:347
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:366
msgid "Individual domains to be blocked."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:204
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:221
msgid "LED to indicate status"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:281
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:299
msgid ""
"Launch all lists downloads and processing simultaneously, reducing service "
"start time."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:183
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:200
msgid "Let local devices use their own DNS servers if set"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:170
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:187
msgid "No AdBlock on dnsmasq"
msgstr ""
@@ -378,15 +377,15 @@ msgstr ""
msgid "Not installed or not found"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:191
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:208
msgid "Output Verbosity Setting"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:219
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:237
msgid "Perform config update before downloading the block/allow-lists."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:206
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:223
msgid "Pick the LED not already used in %sSystem LED Configuration%s."
msgstr ""
@@ -408,11 +407,11 @@ msgstr ""
msgid "Restarting"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:437
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:438
msgid "Service Control"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:282
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:283
msgid "Service Errors"
msgstr ""
@@ -424,15 +423,15 @@ msgstr ""
msgid "Service Warnings"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:279
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:297
msgid "Simultaneous processing"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:371
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:391
msgid "Size: %s"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:195
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:212
msgid "Some output"
msgstr ""
@@ -440,7 +439,7 @@ msgstr ""
msgid "Some recommended packages are missing"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:324
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:325
msgid "Start"
msgstr ""
@@ -448,15 +447,15 @@ msgstr ""
msgid "Starting"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:318
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:319
msgid "Starting %s service"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:362
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:363
msgid "Stop"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:245
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:263
msgid "Stop the download if it is stalled for set number of seconds."
msgstr ""
@@ -464,19 +463,19 @@ msgstr ""
msgid "Stopped"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:356
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/adblock-fast/status.js:357
msgid "Stopping %s service"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:298
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:316
msgid "Store compressed cache"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:292
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:310
msgid "Store compressed cache file on router"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:194
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:211
msgid "Suppress output"
msgstr ""
@@ -506,7 +505,7 @@ msgstr ""
msgid "The dnsmasq nft sets support is enabled, but nft is not installed"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:380
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:403
msgid "URL"
msgstr ""
@@ -515,11 +514,11 @@ msgid ""
"URL to the external dnsmasq config file, see the %sREADME%s for details."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:355
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:374
msgid "URLs to file(s) containing lists to be allowed or blocked."
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:365
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:385
msgid "Unknown"
msgstr ""
@@ -532,13 +531,11 @@ msgid ""
"Use of external dnsmasq config file detected, please set '%s' option to '%s'"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:285
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:286
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:303
msgid "Use simultaneous processing"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:196
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:197
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:213
msgid "Verbose output"
msgstr ""
@@ -573,11 +570,10 @@ msgid "dnsmasq nft set"
msgstr ""
#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:123
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:128
msgid "dnsmasq servers file"
msgstr ""
-#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:209
+#: applications/luci-app-adblock-fast/htdocs/luci-static/resources/view/adblock-fast/overview.js:226
msgid "none"
msgstr ""