summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2023-01-25 00:07:23 +0100
committerGitHub <noreply@github.com>2023-01-25 00:07:23 +0100
commit415dfe473f406af5f9c5ebb8a8a4636d287ea8a6 (patch)
treee748b48cc6bd8a44b848eec7b68d9667d0dd2d65
parent938e54df17d6a48fc8d84fe5893ff67ffe4a3e6e (diff)
parent34dee82f29af74d6dee0616cc52a7b9e4f51d9f6 (diff)
Merge pull request #6211 from dhewg/luci-light
luci-light: rework and reenable
-rw-r--r--collections/luci-light/Makefile15
-rw-r--r--collections/luci-ssl-openssl/Makefile2
-rw-r--r--collections/luci-ssl/Makefile2
-rw-r--r--collections/luci/Makefile13
4 files changed, 18 insertions, 14 deletions
diff --git a/collections/luci-light/Makefile b/collections/luci-light/Makefile
index 9eee97bf9b..d0d1997f04 100644
--- a/collections/luci-light/Makefile
+++ b/collections/luci-light/Makefile
@@ -9,8 +9,19 @@ include $(TOPDIR)/rules.mk
LUCI_TYPE:=col
LUCI_BASENAME:=light
-LUCI_TITLE:=Minimum package set using only admin mini and the standard theme
-LUCI_DEPENDS:=+uhttpd +luci-mod-admin-mini +luci-theme-openwrt @BROKEN
+LUCI_TITLE:=LuCI interface with Uhttpd as Webserver (light)
+LUCI_DESCRIPTION:=Light OpenWrt set including admin support and the default Bootstrap theme
+LUCI_DEPENDS:= \
+ +IPV6:luci-proto-ipv6 \
+ +luci-app-firewall \
+ +luci-mod-admin-full \
+ +luci-proto-ppp \
+ +luci-theme-bootstrap \
+ +rpcd-mod-rrdns \
+ +uhttpd \
+ +uhttpd-mod-ubus
+
+PKG_LICENSE:=Apache-2.0
include ../../luci.mk
diff --git a/collections/luci-ssl-openssl/Makefile b/collections/luci-ssl-openssl/Makefile
index d1e752e8b8..890d224697 100644
--- a/collections/luci-ssl-openssl/Makefile
+++ b/collections/luci-ssl-openssl/Makefile
@@ -14,7 +14,7 @@ LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
-LUCI_DEPENDS:=+luci +libustream-openssl +openssl-util
+LUCI_DEPENDS:=+luci-light +libustream-openssl +openssl-util
include ../../luci.mk
diff --git a/collections/luci-ssl/Makefile b/collections/luci-ssl/Makefile
index 0b4d030702..ea82a5c047 100644
--- a/collections/luci-ssl/Makefile
+++ b/collections/luci-ssl/Makefile
@@ -10,7 +10,7 @@ LUCI_TYPE:=col
LUCI_BASENAME:=ssl
LUCI_TITLE:=LuCI with HTTPS support (WolfSSL as SSL backend)
-LUCI_DEPENDS:=+luci +libustream-wolfssl +px5g-wolfssl
+LUCI_DEPENDS:=+luci-light +libustream-wolfssl +px5g-wolfssl
PKG_LICENSE:=Apache-2.0
diff --git a/collections/luci/Makefile b/collections/luci/Makefile
index 62da8ad259..2e09b78f02 100644
--- a/collections/luci/Makefile
+++ b/collections/luci/Makefile
@@ -10,18 +10,11 @@ LUCI_TYPE:=col
LUCI_BASENAME:=luci
LUCI_TITLE:=LuCI interface with Uhttpd as Webserver (default)
-LUCI_DESCRIPTION:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
+LUCI_DESCRIPTION:=Standard OpenWrt set including package management and attended sysupgrades support
LUCI_DEPENDS:= \
- +IPV6:luci-proto-ipv6 \
+ +luci-light \
+luci-app-attendedsysupgrade \
- +luci-app-firewall \
- +luci-app-opkg \
- +luci-mod-admin-full \
- +luci-proto-ppp \
- +luci-theme-bootstrap \
- +rpcd-mod-rrdns \
- +uhttpd \
- +uhttpd-mod-ubus
+ +luci-app-opkg
PKG_LICENSE:=Apache-2.0