summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-10-23 18:30:56 +0300
committerGitHub <noreply@github.com>2017-10-23 18:30:56 +0300
commit3e00e13e1f2a2518de9e14090384f75b94329d98 (patch)
tree2ad6627973efedeff4c845c86793b69632c24e4d
parent59a4e4065d7ba5711028e03de0f05a60f7130e23 (diff)
parent713d463248773f4c0d8fee1d9c2b8dc0ff0de32c (diff)
Merge pull request #1296 from TDT-GmbH/sort-language
luci.mk: sort languages in lexical order
-rw-r--r--luci.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 1ddb73d49..0b2ec4e70 100644
--- a/luci.mk
+++ b/luci.mk
@@ -7,7 +7,7 @@
LUCI_NAME?=$(notdir ${CURDIR})
LUCI_TYPE?=$(word 2,$(subst -, ,$(LUCI_NAME)))
LUCI_BASENAME?=$(patsubst luci-$(LUCI_TYPE)-%,%,$(LUCI_NAME))
-LUCI_LANGUAGES:=$(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*)))
+LUCI_LANGUAGES:=$(sort $(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*))))
LUCI_DEFAULTS:=$(notdir $(wildcard ${CURDIR}/root/etc/uci-defaults/*))
LUCI_PKGARCH?=$(if $(realpath src/Makefile),,all)