summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2024-10-31 10:05:01 -0700
committerGitHub <noreply@github.com>2024-10-31 10:05:01 -0700
commit23657ad52c3d5d89f79e497681069d25597065fb (patch)
tree00890e8fbb48b86535d4b03c6392088d90c23e4b
parentf9899fd1a38ef2784cebc943a65c741e6cf3685c (diff)
parent2a09205aed273a277dd22ca9937b41728b7ceb9c (diff)
Merge pull request #7368 from stangri/master-luci-app-pbr
luci-app-pbr: update to sync with principal package
-rw-r--r--applications/luci-app-pbr/Makefile2
-rw-r--r--applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js7
-rw-r--r--applications/luci-app-pbr/po/templates/pbr.pot38
-rwxr-xr-xapplications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr2
4 files changed, 28 insertions, 21 deletions
diff --git a/applications/luci-app-pbr/Makefile b/applications/luci-app-pbr/Makefile
index 3405337149..fb166677e6 100644
--- a/applications/luci-app-pbr/Makefile
+++ b/applications/luci-app-pbr/Makefile
@@ -7,7 +7,7 @@ PKG_NAME:=luci-app-pbr
PKG_LICENSE:=AGPL-3.0-or-later
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
PKG_VERSION:=1.1.7
-PKG_RELEASE:=29
+PKG_RELEASE:=47
LUCI_TITLE:=Policy Based Routing Service Web UI
LUCI_URL:=https://github.com/stangri/luci-app-pbr/
diff --git a/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js b/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
index c8675423db..09f746eaa9 100644
--- a/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
+++ b/applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js
@@ -11,7 +11,7 @@ var pkg = {
return "pbr";
},
get ReadmeCompat() {
- return "1.1.7-29";
+ return "1.1.7-39";
},
get URL() {
return (
@@ -267,7 +267,7 @@ var status = baseclass.extend({
),
warningDhcpLanForce: _(
_(
- "Please set 'dhcp.lan.force=1' to speed up service start-up %s(more info)%s"
+ "Please set 'dhcp.%%s.force=1' to speed up service start-up %s(more info)%s"
).format(
"<a href='" +
pkg.URL +
@@ -409,6 +409,9 @@ var status = baseclass.extend({
errorDefaultFw4TableMissing: _("Default fw4 table '%s' is missing"),
errorDefaultFw4ChainMissing: _("Default fw4 chain '%s' is missing"),
errorRequiredBinaryMissing: _("Required binary '%s' is missing"),
+ errorInterfaceRoutingUnknownDevType: _(
+ "Unknown IPv6 Link type for device '%s'"
+ ),
};
var errorsTitle = E(
"label",
diff --git a/applications/luci-app-pbr/po/templates/pbr.pot b/applications/luci-app-pbr/po/templates/pbr.pot
index 281d5b7921..cd347bff33 100644
--- a/applications/luci-app-pbr/po/templates/pbr.pot
+++ b/applications/luci-app-pbr/po/templates/pbr.pot
@@ -113,7 +113,7 @@ msgstr ""
msgid "Default fw4 table '%s' is missing"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:542
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:545
msgid "Disable"
msgstr ""
@@ -123,7 +123,7 @@ msgstr ""
msgid "Disabled"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:536
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:539
msgid "Disabling %s service"
msgstr ""
@@ -149,11 +149,11 @@ msgstr ""
msgid "Do not enforce policies when their gateway is down"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:589
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:592
msgid "Donate to the Project"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:523
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:526
msgid "Enable"
msgstr ""
@@ -165,7 +165,7 @@ msgstr ""
msgid "Enabled"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:517
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:520
msgid "Enabling %s service"
msgstr ""
@@ -173,7 +173,7 @@ msgstr ""
msgid "Error running custom user file '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:431
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:434
msgid "Errors encountered, please check the %sREADME%s"
msgstr ""
@@ -332,7 +332,7 @@ msgid "Path"
msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:215
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:597
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:600
msgid "Please %sdonate%s to support development of this project."
msgstr ""
@@ -342,7 +342,7 @@ msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:270
msgid ""
-"Please set 'dhcp.lan.force=1' to speed up service start-up %s(more info)%s"
+"Please set 'dhcp.%%s.force=1' to speed up service start-up %s(more info)%s"
msgstr ""
#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:248
@@ -452,11 +452,11 @@ msgid ""
"Resolver set support (%s) requires nftables, but nft binary cannot be found"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:485
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:488
msgid "Restart"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:479
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:482
msgid "Restarting %s service"
msgstr ""
@@ -482,11 +482,11 @@ msgstr ""
msgid "Select Add for -A/add and Insert for -I/Insert."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:568
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:571
msgid "Service Control"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:416
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:419
msgid "Service Errors"
msgstr ""
@@ -517,11 +517,11 @@ msgstr ""
msgid "Skipping IPv6 policy '%s' as IPv6 support is disabled"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:466
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:469
msgid "Start"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:460
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:463
msgid "Starting %s service"
msgstr ""
@@ -535,7 +535,7 @@ msgstr ""
msgid "Status"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:504
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:507
msgid "Stop"
msgstr ""
@@ -547,7 +547,7 @@ msgstr ""
msgid "Stopped."
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:498
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:501
msgid "Stopping %s service"
msgstr ""
@@ -625,7 +625,11 @@ msgstr ""
msgid "Unexpected exit or service termination: '%s'"
msgstr ""
-#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:428
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:413
+msgid "Unknown IPv6 Link type for device '%s'"
+msgstr ""
+
+#: applications/luci-app-pbr/htdocs/luci-static/resources/pbr/status.js:431
msgid "Unknown error!"
msgstr ""
diff --git a/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr b/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
index 25bb277c72..477137f904 100755
--- a/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
+++ b/applications/luci-app-pbr/root/usr/libexec/rpcd/luci.pbr
@@ -11,7 +11,7 @@
# ubus -S call luci.pbr getGateways '{"name": "pbr" }'
# ubus -S call luci.pbr getInterfaces '{"name": "pbr" }'
-readonly luciCompat='9'
+readonly luciCompat='11'
readonly pbrFunctionsFile='/etc/init.d/pbr'
if [ -s "$pbrFunctionsFile" ]; then
# shellcheck source=../../../../../pbr/files/etc/init.d/pbr