summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-12-10 11:20:01 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2016-12-10 11:20:01 +0200
commitdad185e2c9b57f458fdc8701f401e6956eaaa406 (patch)
treedd8e8545f5c5e18977a046a70d4563319adcc32c
parenta7c5c018b6782f4160410981c723c82db9762ff7 (diff)
Fix config files getting overwritten in opkg install
Commit 39ff053890 accidentally removed the conffiles definitions from luci-base, statistics, splash and diag-devinfo apps. That has caused existing config files to get overwritten if the package has been reinstalled via opkg. Additionally, the splash text files have not been saved in sysupgrade or backup as they are located outside /etc/config This commit adds back the conffiles definitions to the respective packages. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
-rw-r--r--applications/luci-app-diag-devinfo/Makefile4
-rw-r--r--applications/luci-app-splash/Makefile6
-rw-r--r--applications/luci-app-statistics/Makefile4
-rw-r--r--modules/luci-base/Makefile1
4 files changed, 15 insertions, 0 deletions
diff --git a/applications/luci-app-diag-devinfo/Makefile b/applications/luci-app-diag-devinfo/Makefile
index 0424fffa0..1505b6212 100644
--- a/applications/luci-app-diag-devinfo/Makefile
+++ b/applications/luci-app-diag-devinfo/Makefile
@@ -9,6 +9,10 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=LuCI Diagnostics Tools (Device Info)
LUCI_DEPENDS:=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo @BROKEN
+define Package/luci-app-diag-devinfo/conffiles
+/etc/config/luci_devinfo
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-splash/Makefile b/applications/luci-app-splash/Makefile
index 345f8910f..5740aa5f7 100644
--- a/applications/luci-app-splash/Makefile
+++ b/applications/luci-app-splash/Makefile
@@ -9,6 +9,12 @@ include $(TOPDIR)/rules.mk
LUCI_TITLE:=Freifunk DHCP-Splash application
LUCI_DEPENDS:=+luci-lib-nixio +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
+define Package/luci-app-splash/conffiles
+/etc/config/luci_splash
+/usr/lib/luci-splash/splashtext.html
+/usr/lib/luci-splash/splashtextinclude.html
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-statistics/Makefile b/applications/luci-app-statistics/Makefile
index 6c0121e96..008792a5d 100644
--- a/applications/luci-app-statistics/Makefile
+++ b/applications/luci-app-statistics/Makefile
@@ -12,6 +12,10 @@ LUCI_DEPENDS:= \
+collectd-mod-cpu +collectd-mod-memory \
+collectd-mod-interface +collectd-mod-load +collectd-mod-network
+define Package/luci-app-statistics/conffiles
+/etc/config/luci_statistics
+endef
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 972a451c6..ce7d40dac 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Package/luci-base/conffiles
/etc/luci-uploads
+/etc/config/luci
endef
include ../../luci.mk