summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2016-05-29 14:56:51 +0100
committerKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2016-06-03 10:24:09 +0100
commit4580faaa5e1e3988ea806deafb70071a58250473 (patch)
tree386b2c74f32c0b00646bcaf12943a7092efe6039
parent1709800150565fd027a3a9b752687439f53460ab (diff)
luci-base: fix lua interpreter location
An lua interpreter is required on the building host to run the luasrcdiet lua script. Due to a build change, the interpreter was not being installed to the correct location. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
-rw-r--r--luci.mk2
-rw-r--r--modules/luci-base/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/luci.mk b/luci.mk
index 5b32dab2f..eb034d208 100644
--- a/luci.mk
+++ b/luci.mk
@@ -150,7 +150,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
define SrcDiet
$(FIND) $(1) -type f -name '*.lua' | while read src; do \
- if $(STAGING_DIR_HOST)/bin/lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet \
+ if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \
--noopt-binequiv -o "$$$$src.o" "$$$$src"; \
then mv "$$$$src.o" "$$$$src"; fi; \
done
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index a9c5e71cb..f0763cb1d 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,9 +37,10 @@ define Host/Compile
endef
define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR)/host/bin
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
$(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR_HOST)/bin/LuaSrcDiet
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))