summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-09-15 16:49:56 +0000
committerSteven Barth <steven@midlink.org>2008-09-15 16:49:56 +0000
commit22c927621c18e384f3f79e53aedda53271d52de2 (patch)
tree7363c508763f2efb0b2bb726f2e2dfa20e7c776e
parent25263f014408448f3f153d9a62ab3d1de4b17660 (diff)
Optimized caching behaviour, automatically flush caches in dev environment
-rw-r--r--Makefile1
-rw-r--r--libs/core/luasrc/ccache.lua2
-rwxr-xr-xlibs/sgi-cgi/htdocs/cgi-bin/luci2
-rw-r--r--libs/web/root/etc/config/luci4
4 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index c90f11fc9..acb6659df 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,7 @@ hostcopy:
for i in $(MODULES); do cp -a $$i/hostfiles/* host/ -R 2>/dev/null || true; done
rm -f host/luci
ln -s .$(LUCI_MODULEDIR) host/luci
+ rm -rf /tmp/luci-* || true
hostenv: host ucidefaults
diff --git a/libs/core/luasrc/ccache.lua b/libs/core/luasrc/ccache.lua
index 437d38525..83e82d9fd 100644
--- a/libs/core/luasrc/ccache.lua
+++ b/libs/core/luasrc/ccache.lua
@@ -32,7 +32,7 @@ function cache_ondemand(...)
end
function cache_enable(cachepath, mode)
- cachepath = cachepath or "/tmp/.luciccache"
+ cachepath = cachepath or "/tmp/luci-modulecache"
mode = mode or "r--r--r--"
local loader = package.loaders[2]
diff --git a/libs/sgi-cgi/htdocs/cgi-bin/luci b/libs/sgi-cgi/htdocs/cgi-bin/luci
index cd9bb5966..529d1d0bc 100755
--- a/libs/sgi-cgi/htdocs/cgi-bin/luci
+++ b/libs/sgi-cgi/htdocs/cgi-bin/luci
@@ -1,5 +1,5 @@
#!/usr/bin/lua
require "luci.cacheloader"
require "luci.sgi.cgi"
-luci.dispatcher.indexcache = "/tmp/.luciindex"
+luci.dispatcher.indexcache = "/tmp/luci-indexcache"
luci.sgi.cgi.run() \ No newline at end of file
diff --git a/libs/web/root/etc/config/luci b/libs/web/root/etc/config/luci
index f78fbb02b..4e31f9d9b 100644
--- a/libs/web/root/etc/config/luci
+++ b/libs/web/root/etc/config/luci
@@ -21,7 +21,7 @@ config extern flash_keep
config internal languages
config internal sauth
- option sessionpath "/tmp/.lucisessions"
+ option sessionpath "/tmp/luci-sessions"
option sessiontime 3600
config internal ccache
@@ -29,6 +29,6 @@ config internal ccache
config internal template
option compiler_mode file
- option compiledir "/tmp/.lucitplcache"
+ option compiledir "/tmp/luci-templatecache"
config internal themes