summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSophana KOK <ml-github@worldspot.net>2016-06-07 09:25:15 +0200
committerJo-Philipp Wich <jo@mein.io>2018-09-27 21:12:40 +0200
commitf405d239900b3a292c811c2fdd6e5d2bf14a169f (patch)
treea1fa564ae39803ac1b1969022734922e2fe0cdd3
parent874faa9223752ebf043e5e639de7f233aef8da83 (diff)
restored nixio tls providers
Signed-off-by: Sophana KOK <ml-github@worldspot.net>
-rw-r--r--libs/luci-lib-nixio/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/Makefile b/libs/luci-lib-nixio/Makefile
index bec5f83cd..4e501b89c 100644
--- a/libs/luci-lib-nixio/Makefile
+++ b/libs/luci-lib-nixio/Makefile
@@ -11,6 +11,44 @@ LUCI_DEPENDS:=+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio
PKG_LICENSE:=Apache-2.0
+define Package/luci-lib-nixio/config
+ choice
+ prompt "TLS Provider"
+ default PACKAGE_luci-lib-nixio_notls
+
+ config PACKAGE_luci-lib-nixio_notls
+ bool "Disabled"
+
+ config PACKAGE_luci-lib-nixio_axtls
+ bool "Builtin (axTLS)"
+
+ config PACKAGE_luci-lib-nixio_cyassl
+ bool "CyaSSL"
+ select PACKAGE_libcyassl
+
+ config PACKAGE_luci-lib-nixio_openssl
+ bool "OpenSSL"
+ select PACKAGE_libopenssl
+ endchoice
+endef
+
+NIXIO_TLS:=
+
+ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_axtls),)
+ NIXIO_TLS:=axtls
+endif
+
+ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_openssl),)
+ NIXIO_TLS:=openssl
+endif
+
+ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_cyassl),)
+ NIXIO_TLS:=cyassl
+ LUCI_CFLAGS+=-I$(STAGING_DIR)/usr/include/cyassl
+endif
+
+MAKE_VARS += NIXIO_TLS="$(NIXIO_TLS)"
+
include ../../luci.mk
# call BuildPackage - OpenWrt buildroot signature