diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2016-03-11 12:23:37 +0100 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2016-03-11 12:23:37 +0100 |
commit | ecb9ee8e5d986a68d681e207e54b63a7d9effb24 (patch) | |
tree | a624ec0aa1e192841c8752b534efd92b9586a3c9 | |
parent | ac9b31ca462b5662e98a0ac6b57fb49c4c4e32de (diff) | |
parent | 7553654bb10af9206cff9837a485b828d1998213 (diff) |
Merge pull request #669 from hnyman/git-branch
LuCI: Display the proper LuCI git branch in GUI
-rw-r--r-- | luci.mk | 15 | ||||
-rw-r--r-- | modules/luci-base/src/Makefile | 2 | ||||
-rwxr-xr-x | modules/luci-base/src/mkversion.sh | 25 |
3 files changed, 16 insertions, 26 deletions
@@ -66,6 +66,19 @@ PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \ echo "$$revision" \ ))) +PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \ + variant="LuCI"; \ + if git log -1 >/dev/null 2>/dev/null; then \ + branch="$$(git symbolic-ref --short -q HEAD 2>/dev/null)"; \ + if [ "$$branch" != "master" ]; then \ + variant="LuCI $$branch branch"; \ + else \ + variant="LuCI Master"; \ + fi; \ + fi; \ + echo "$$variant" \ +))) + PKG_RELEASE?=1 PKG_INSTALL:=$(if $(realpath src/Makefile),1) PKG_BUILD_DEPENDS += lua/host luci-base/host $(LUCI_BUILD_DEPENDS) @@ -121,7 +134,7 @@ endef ifneq ($(wildcard ${CURDIR}/src/Makefile),) MAKE_PATH := src/ - MAKE_VARS += FPIC="$(FPIC)" LUCI_VERSION="$(PKG_VERSION)" + MAKE_VARS += FPIC="$(FPIC)" LUCI_VERSION="$(PKG_VERSION)" LUCI_GITBRANCH="$(PKG_GITBRANCH)" define Build/Compile $(call Build/Compile/Default,clean compile) diff --git a/modules/luci-base/src/Makefile b/modules/luci-base/src/Makefile index 7bb7f2ebe..03e887e1d 100644 --- a/modules/luci-base/src/Makefile +++ b/modules/luci-base/src/Makefile @@ -11,7 +11,7 @@ parser.so: template_parser.o template_utils.o template_lmo.o template_lualib.o $(CC) $(LDFLAGS) -shared -o $@ $^ version.lua: - ./mkversion.sh $@ $(LUCI_VERSION) + ./mkversion.sh $@ $(LUCI_VERSION) "$(LUCI_GITBRANCH)" compile: parser.so version.lua diff --git a/modules/luci-base/src/mkversion.sh b/modules/luci-base/src/mkversion.sh index 55b0ebd22..33c7a3ffe 100755 --- a/modules/luci-base/src/mkversion.sh +++ b/modules/luci-base/src/mkversion.sh @@ -1,28 +1,5 @@ #!/bin/sh -if svn info >/dev/null 2>/dev/null; then - if [ "${4%%/*}" = "branches" ]; then - variant="LuCI ${4##*[-/]} Branch" - elif [ "${4%%/*}" = "tags" ]; then - variant="LuCI ${4##*[-/]} Release" - else - variant="LuCI Trunk" - fi -elif git status >/dev/null 2>/dev/null; then - tag="$(git describe --tags 2>/dev/null)" - branch="$(git symbolic-ref --short -q HEAD 2>/dev/null)" - - if [ -n "$tag" ]; then - variant="LuCI $tag Release" - elif [ "$branch" != "master" ]; then - variant="LuCI ${branch##*-} Branch" - else - variant="LuCI Master" - fi -else - variant="LuCI" -fi - cat <<EOF > $1 local pcall, dofile, _G = pcall, dofile, _G @@ -36,6 +13,6 @@ else distversion = "Development Snapshot" end -luciname = "$variant" +luciname = "${3:-LuCI}" luciversion = "${2:-Git}" EOF |