summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-21 18:02:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-21 18:02:49 +0000
commitd87fefbda608d1bbf296cc7fbb766e72b8b94c13 (patch)
tree6554dc56a790404010496e0dcd67bd60f0fb9fbd
parentbe8a41822c51088fc1ed04e27c77bea3e885df1b (diff)
contrib/package: add package definition for luci-sgi-uhttpd
-rw-r--r--contrib/package/luci/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index a5ba53013..135fb994f 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -771,6 +771,17 @@ define Package/luci-sgi-cgi/install
$(call Package/luci/install/template,$(1),libs/sgi-cgi)
endef
+define Package/luci-sgi-uhttpd
+ $(call Package/luci/webservertemplate)
+ TITLE:=Binding for the uHTTPd server
+ DEPENDS+=+uhttpd
+endef
+
+define Package/luci-sgi-uhttpd/install
+ $(call Package/luci/install/template,$(1),libs/sgi-uhttpd)
+endef
+
+
### Themes ###
define Package/luci-theme-base
$(call Package/luci/thtemplate)
@@ -1150,6 +1161,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
PKG_SELECTED_MODULES+=libs/sgi-cgi
endif
+ifneq ($(CONFIG_PACKAGE_luci-sgi-uhttpd),)
+ PKG_SELECTED_MODULES+=libs/sgi-uhttpd
+endif
ifneq ($(CONFIG_PACKAGE_luci-sgi-luci),)
PKG_SELECTED_MODULES+=libs/sgi-luci
endif
@@ -1278,6 +1292,7 @@ $(eval $(call BuildPackage,luci-app-openvpn))
$(eval $(call BuildPackage,luci-app-p2pblock))
$(eval $(call BuildPackage,luci-sgi-cgi))
+$(eval $(call BuildPackage,luci-sgi-uhttpd))
$(eval $(call BuildPackage,luci-theme-base))
$(eval $(call BuildPackage,luci-theme-fledermaus))