summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-06-20 07:20:56 +0000
committerSteven Barth <steven@midlink.org>2009-06-20 07:20:56 +0000
commita060a9e135ce0bf94496935aea5a4981ca0da750 (patch)
tree0fa2894746474645cc038c94cc386c874c9f814b
parent341f757255caa08ee2922a3f32a00849e306f23c (diff)
Fix SDK build process
-rw-r--r--Makefile9
-rw-r--r--build/lucid.lua2
-rw-r--r--contrib/lar/Makefile1
3 files changed, 4 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index d082a9807..13438848e 100644
--- a/Makefile
+++ b/Makefile
@@ -50,15 +50,8 @@ hostenv: host ucidefaults
ucidefaults:
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host)/bin/uci-defaults --exclude luci-freifunk-*"
-runboa: hostenv
- libs/sgi-webuci/host/buildconfig.sh $(realpath host) > host/etc/boa/boa.conf
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/boa) -c $(realpath host/etc/boa) -d"
-
runhttpd: hostenv
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath host/usr/bin/lucittpd) $(realpath host)/usr/lib/lucittpd/plugins"
-
-runluci: luahost
- build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "$(realpath libs/httpd/host/runluci) $(realpath host) $(HTDOCS)"
+ build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua build/lucid.lua"
runlua: hostenv
build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "lua -i build/setup.lua"
diff --git a/build/lucid.lua b/build/lucid.lua
new file mode 100644
index 000000000..71e4fd258
--- /dev/null
+++ b/build/lucid.lua
@@ -0,0 +1,2 @@
+dofile "build/setup.lua"
+require "luci.lucid".start()
diff --git a/contrib/lar/Makefile b/contrib/lar/Makefile
index cc328de6d..5199546e7 100644
--- a/contrib/lar/Makefile
+++ b/contrib/lar/Makefile
@@ -5,6 +5,7 @@ LDFLAGS :=
OBJ = cli.o lar.o md5.o
BIN = lar
+compile:
cli: $(OBJ)
$(GCC) $(CFLAGS) -o $(BIN) $(OBJ) $(LDFLAGS)