summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-07-12 22:05:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-07-12 22:05:04 +0000
commit9548b528b66fdc0c30ca0576945bcff9f568388a (patch)
tree912c52ddebd7214220ea48987f480dc222150707
parentdfe0287c6fbab70c359f97c4b9d72a53bc5ff0e2 (diff)
* luci: added community package for Freifunk Augsburg
-rw-r--r--applications/community-augsburg/Makefile2
-rw-r--r--applications/community-augsburg/ipkg/postinst4
-rw-r--r--applications/community-augsburg/root/etc/uci-defaults/luci-community-augsburg16
-rw-r--r--contrib/package/luci/Makefile17
4 files changed, 39 insertions, 0 deletions
diff --git a/applications/community-augsburg/Makefile b/applications/community-augsburg/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/applications/community-augsburg/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/applications/community-augsburg/ipkg/postinst b/applications/community-augsburg/ipkg/postinst
new file mode 100644
index 000000000..b99b7c17c
--- /dev/null
+++ b/applications/community-augsburg/ipkg/postinst
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+ ( . /etc/uci-defaults/luci-community-augsburg ) && rm -f /etc/uci-defaults/luci-community-augsburg
+}
diff --git a/applications/community-augsburg/root/etc/uci-defaults/luci-community-augsburg b/applications/community-augsburg/root/etc/uci-defaults/luci-community-augsburg
new file mode 100644
index 000000000..b1efd46de
--- /dev/null
+++ b/applications/community-augsburg/root/etc/uci-defaults/luci-community-augsburg
@@ -0,0 +1,16 @@
+#!/bin/sh
+uci batch <<-EOF
+ set freifunk.community.name='Freifunk Augsburg'
+ set freifunk.community.homepage=http://augsburg.freifunk.net
+ set freifunk.community.essid=augsburg.freifunk.net
+ set freifunk.community.bssid=02:CA:FF:EE:BA:BE
+ set freifunk.community.channel=1
+ set freifunk.community.net=191.161.0.0
+ set freifunk.community.mask=255.255.0.0
+ set freifunk.community.dns='88.198.178.18 141.54.1.1 212.204.49.83 208.67.220.220 208.67.222.222'
+ set luci.main.mediaurlbase=/luci-static/fledermaus
+ set luci.main.lang=de
+ commit freifunk
+ commit luci
+EOF
+
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 6dd43f717..2c30695e7 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -267,6 +267,19 @@ define Package/luci-ff-berlin/install
$(call Package/luci/install/template,$(1),applications/community-berlin)
endef
+define Package/luci-ff-augsburg
+ $(call Package/luci/fftemplate)
+ DEPENDS+= \
+ +luci-sgi-cgi +luci-app-splash +luci-app-olsr \
+ +luci-theme-fledermaus \
+ +luci-i18n-german \
+ +olsrd +olsrd-mod-dyn-gw +olsrd-mod-txtinfo +olsrd-mod-nameservice
+ TITLE:=Freifunk Augsburg Community Meta-Package
+endef
+
+define Package/luci-ff-augsburg/install
+ $(call Package/luci/install/template,$(1),applications/community-augsburg)
+endef
### Modules ###
@@ -496,6 +509,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-ff-berlin),)
PKG_SELECTED_MODULES+=applications/community-berlin
endif
+ifneq ($(CONFIG_PACKAGE_luci-ff-augsburg),)
+ PKG_SELECTED_MODULES+=applications/community-augsburg
+endif
ifneq ($(CONFIG_PACKAGE_luci-mod-admin-core),)
PKG_SELECTED_MODULES+=modules/admin-core
@@ -573,6 +589,7 @@ $(eval $(call BuildPackage,luci-ff-halle))
$(eval $(call BuildPackage,luci-ff-leipzig))
$(eval $(call BuildPackage,luci-ff-hannover))
$(eval $(call BuildPackage,luci-ff-berlin))
+$(eval $(call BuildPackage,luci-ff-augsburg))
$(eval $(call BuildPackage,luci-mod-admin-core))
$(eval $(call BuildPackage,luci-mod-freifunk))