summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-09-19 13:31:25 +0300
committerGitHub <noreply@github.com>2016-09-19 13:31:25 +0300
commit51e087e55ff0aaadcd8d5f0b50207aba40c48c29 (patch)
treea99e1fa69b5a9c6466f5534ef665ba6392573c35
parent44bf3f0c1640040561306caff39f34ac916b4357 (diff)
parenta4c8c206477b1c8d4fb60dcb73d777c9c9183e81 (diff)
Merge pull request #799 from kuoruan/aria2
luci-app-aria2: fix and update
-rw-r--r--applications/luci-app-aria2/Makefile24
-rw-r--r--applications/luci-app-aria2/luasrc/model/cbi/aria2.lua21
-rw-r--r--applications/luci-app-aria2/luasrc/view/aria2/overview_status.htm (renamed from applications/luci-app-aria2/luasrc/view/aria2/web_script.htm)2
-rw-r--r--applications/luci-app-aria2/po/templates/aria2.pot (renamed from applications/luci-app-aria2/po/templates/aria2.po)24
-rw-r--r--applications/luci-app-aria2/po/zh-cn/aria2.po32
5 files changed, 95 insertions, 8 deletions
diff --git a/applications/luci-app-aria2/Makefile b/applications/luci-app-aria2/Makefile
index 0179f04f4..f5b006c35 100644
--- a/applications/luci-app-aria2/Makefile
+++ b/applications/luci-app-aria2/Makefile
@@ -6,8 +6,32 @@
include $(TOPDIR)/rules.mk
+PKG_NAME:=luci-app-aria2
+
+# Version == major.minor.patch
+# increase "minor" on new functionality and "patch" on patches/optimization
+PKG_VERSION:=1.0.1
+
+# Release == build
+# increase on changes of translation files
+PKG_RELEASE:=2
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Hsing-Wang Liao <kuoruan@gmail.com>
+
+# LuCI specific settings
LUCI_TITLE:=LuCI Support for Aria2
LUCI_DEPENDS:=+aria2
+LUCI_PKGARCH:=all
+
+define Package/$(PKG_NAME)/config
+# shown in make menuconfig <Help>
+help
+ $(LUCI_TITLE)
+ .
+ Version: $(PKG_VERSION)-$(PKG_RELEASE)
+ $(PKG_MAINTAINER)
+endef
include ../../luci.mk
diff --git a/applications/luci-app-aria2/luasrc/model/cbi/aria2.lua b/applications/luci-app-aria2/luasrc/model/cbi/aria2.lua
index 780aea33d..f713ad5be 100644
--- a/applications/luci-app-aria2/luasrc/model/cbi/aria2.lua
+++ b/applications/luci-app-aria2/luasrc/model/cbi/aria2.lua
@@ -80,19 +80,32 @@ o.rmempty = false
o = s:taboption("general", Value, "rpc_passwd", translate("RPC password"))
o:depends("rpc_auth_method", "user_pass")
o.password = true
-o.rmempty = false
+o.rmempty = true
o = s:taboption("general", Value, "rpc_secret", translate("RPC Token"), "<br/>" .. cfgbtn)
o:depends("rpc_auth_method", "token")
-o.rmempty = false
+o.rmempty = true
o = s:taboption("file", Value, "config_dir", translate("Config file directory"))
o.placeholder = "/var/etc/aria2"
+o = s:taboption("file", Flag, "enable_log", translate("Enable log"), translate("Log file is in the config file dir."))
+o.enabled = "true"
+o.disabled = "false"
+
+o = s:taboption("file", ListValue, "log_level", translate("Log level"))
+o:depends("enable_log", "true")
+o:value("debug", translate("Debug"))
+o:value("info", translate("Info"))
+o:value("notice", translate("Notice"))
+o:value("warn", translate("Warn"))
+o:value("error", translate("Error"))
+
o = s:taboption("file", Value, "dir", translate("Default download directory"))
o.rmempty = false
-s:taboption("file", Value, "disk_cache", translate("Disk cache"), translate("in bytes, You can append K or M."))
+o = s:taboption("file", Value, "disk_cache", translate("Disk cache"), translate("in bytes, You can append K or M."))
+o.rmempty = true
o = s:taboption("file", ListValue, "file_allocation", translate("Preallocation"), translate("\"Falloc\" is not available in all cases."))
o:value("none", translate("Off"))
@@ -101,6 +114,7 @@ o:value("trunc", translate("Trunc"))
o:value("falloc", translate("Falloc"))
overall_speed_limit = s:taboption("task", Flag, "overall_speed_limit", translate("Overall speed limit enabled"))
+overall_speed_limit.rmempty = true
o = s:taboption("task", Value, "max_overall_download_limit", translate("Overall download limit"), translate("in bytes/sec, You can append K or M."))
o:depends("overall_speed_limit", "1")
@@ -109,6 +123,7 @@ o = s:taboption("task", Value, "max_overall_upload_limit", translate("Overall up
o:depends("overall_speed_limit", "1")
task_speed_limit = s:taboption("task", Flag, "task_speed_limit", translate("Per task speed limit enabled"))
+task_speed_limit.rmempty = true
o = s:taboption("task", Value, "max_download_limit", translate("Per task download limit"), translate("in bytes/sec, You can append K or M."))
o:depends("task_speed_limit", "1")
diff --git a/applications/luci-app-aria2/luasrc/view/aria2/web_script.htm b/applications/luci-app-aria2/luasrc/view/aria2/overview_status.htm
index 933c6af70..b14cca228 100644
--- a/applications/luci-app-aria2/luasrc/view/aria2/web_script.htm
+++ b/applications/luci-app-aria2/luasrc/view/aria2/overview_status.htm
@@ -1,5 +1,5 @@
<script type="text/javascript">//<![CDATA[
-XHR.poll(5, '<%=url([[admin]], [[services]], [[aria2]], [[status]])%>', null,
+XHR.poll(5, '<%=luci.dispatcher.build_url("admin/services/aria2/status")%>', null,
function(x, data) {
var tb = document.getElementById('aria2_status');
if (data && tb) {
diff --git a/applications/luci-app-aria2/po/templates/aria2.po b/applications/luci-app-aria2/po/templates/aria2.pot
index 353d48ece..9cf7099d0 100644
--- a/applications/luci-app-aria2/po/templates/aria2.po
+++ b/applications/luci-app-aria2/po/templates/aria2.pot
@@ -67,6 +67,30 @@ msgstr ""
msgid "Generate Randomly"
msgstr ""
+msgid "Enable log"
+msgstr ""
+
+msgid "Log file is in the config file dir."
+msgstr ""
+
+msgid "Log level"
+msgstr ""
+
+msgid "Debug"
+msgstr ""
+
+msgid "Info"
+msgstr ""
+
+msgid "Notice"
+msgstr ""
+
+msgid "Warn"
+msgstr ""
+
+msgid "Error"
+msgstr ""
+
msgid "Config file directory"
msgstr ""
diff --git a/applications/luci-app-aria2/po/zh-cn/aria2.po b/applications/luci-app-aria2/po/zh-cn/aria2.po
index 9b7d7bcc2..823699d7b 100644
--- a/applications/luci-app-aria2/po/zh-cn/aria2.po
+++ b/applications/luci-app-aria2/po/zh-cn/aria2.po
@@ -2,7 +2,7 @@ msgid "Aria2"
msgstr ""
msgid "Aria2 is a multi-protocol &amp; multi-source download utility, here you can configure the settings."
-msgstr "Aria2 是一个支持多协议多线程的下载器, 你可以在这里对其进行配置."
+msgstr "Aria2 是一个支持多协议多线程的下载器, 你可以在这里对其进行配置"
msgid "Aria2 Status"
msgstr "Aria2 状态"
@@ -67,6 +67,30 @@ msgstr "RPC令牌"
msgid "Generate Randomly"
msgstr "随机生成"
+msgid "Enable log"
+msgstr "启用日志"
+
+msgid "Log file is in the config file dir."
+msgstr "日志文件在配置文件目录下"
+
+msgid "Log level"
+msgstr "日志记录等级"
+
+msgid "Debug"
+msgstr "调试"
+
+msgid "Info"
+msgstr "信息"
+
+msgid "Notice"
+msgstr "注意"
+
+msgid "Warn"
+msgstr "警告"
+
+msgid "Error"
+msgstr "错误"
+
msgid "Config file directory"
msgstr "配置文件目录"
@@ -77,7 +101,7 @@ msgid "Disk cache"
msgstr "磁盘缓存"
msgid "in bytes, You can append K or M."
-msgstr "单位 B, 你可以在数字后跟上 K 或 M."
+msgstr "单位 B, 你可以在数字后跟上 K 或 M"
msgid "Preallocation"
msgstr "磁盘预分配"
@@ -95,7 +119,7 @@ msgid "Falloc"
msgstr ""
msgid "\"Falloc\" is not available in all cases."
-msgstr "\"Falloc\" 并不是在所有情况下都可用."
+msgstr "\"Falloc\" 并不是在所有情况下都可用"
msgid "Overall speed limit enabled"
msgstr "启用全局限速"
@@ -104,7 +128,7 @@ msgid "Overall download limit"
msgstr "全局下载限速"
msgid "in bytes/sec, You can append K or M."
-msgstr "单位 B/s, 你可以在数字后跟上 K 或 M."
+msgstr "单位 B/s, 你可以在数字后跟上 K 或 M"
msgid "Overall upload limit"
msgstr "全局上传限速"