summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2018-03-15 15:28:18 +0100
committerYousong Zhou <yszhou4tech@gmail.com>2018-09-30 17:49:09 +0800
commit24cf28b5ec148bc29d2d150e94f8928d96c1d1e6 (patch)
tree841f1af983687629b9f82c208ba2f4775fcf1c44
parentcd1bce501700adba29d70aeea0c191cc05a692a3 (diff)
luci-proto-pppossh: move pppossh to own package
This is a special proto which should go into a separate package. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua8
-rw-r--r--protocols/luci-proto-pppossh/Makefile17
-rw-r--r--protocols/luci-proto-pppossh/luasrc/model/cbi/admin_network/proto_pppossh.lua (renamed from protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua)0
-rw-r--r--protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua40
4 files changed, 58 insertions, 7 deletions
diff --git a/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua b/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
index 3afb7de4f..f87b30fcc 100644
--- a/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
+++ b/protocols/luci-proto-ppp/luasrc/model/network/proto_ppp.lua
@@ -4,7 +4,7 @@
local netmod = luci.model.network
local _, p
-for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
+for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp"}) do
local proto = netmod:register_protocol(p)
@@ -19,8 +19,6 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
return luci.i18n.translate("PPPoATM")
elseif p == "l2tp" then
return luci.i18n.translate("L2TP")
- elseif p == "pppossh" then
- return luci.i18n.translate("PPPoSSH")
end
end
@@ -39,8 +37,6 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
return "ppp-mod-pppoa"
elseif p == "l2tp" then
return "xl2tpd"
- elseif p == "pppossh" then
- return "pppossh"
end
end
@@ -53,8 +49,6 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "l2tp", "pppossh"}) do
return (nixio.fs.glob("/usr/lib/pppd/*/pptp.so")() ~= nil)
elseif p == "l2tp" then
return nixio.fs.access("/lib/netifd/proto/l2tp.sh")
- elseif p == "pppossh" then
- return nixio.fs.access("/lib/netifd/proto/pppossh.sh")
else
return nixio.fs.access("/lib/netifd/proto/ppp.sh")
end
diff --git a/protocols/luci-proto-pppossh/Makefile b/protocols/luci-proto-pppossh/Makefile
new file mode 100644
index 000000000..1c0a63b0f
--- /dev/null
+++ b/protocols/luci-proto-pppossh/Makefile
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2018 Florian Eckert <fe@dev.tdt.de>
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TITLE:=Support for pppossh
+LUCI_DEPENDS:=+pppossh
+
+PKG_LICENSE:=Apache-2.0
+PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua b/protocols/luci-proto-pppossh/luasrc/model/cbi/admin_network/proto_pppossh.lua
index e53262b5d..e53262b5d 100644
--- a/protocols/luci-proto-ppp/luasrc/model/cbi/admin_network/proto_pppossh.lua
+++ b/protocols/luci-proto-pppossh/luasrc/model/cbi/admin_network/proto_pppossh.lua
diff --git a/protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua b/protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua
new file mode 100644
index 000000000..a0e2a510c
--- /dev/null
+++ b/protocols/luci-proto-pppossh/luasrc/model/network/proto_pppossh.lua
@@ -0,0 +1,40 @@
+-- Copyright 2018 Florian Eckert <fe@dev.tdt.de>
+-- Licensed to the public under the Apache License 2.0.
+
+local netmod = luci.model.network
+
+local proto = netmod:register_protocol("pppossh")
+
+function proto.get_i18n(self)
+ return luci.i18n.translate("PPPoSSH")
+end
+
+function proto.ifname(self)
+ return "pppossh-" .. self.sid
+end
+
+function proto.opkg_package(self)
+ return "pppossh"
+end
+
+function proto.is_installed(self)
+ return nixio.fs.access("/lib/netifd/proto/pppossh.sh")
+end
+
+function proto.is_floating(self)
+ return true
+end
+
+function proto.is_virtual(self)
+ return true
+end
+
+function proto.get_interfaces(self)
+ return nil
+end
+
+function proto.contains_interface(self, ifc)
+ return (netmod:ifnameof(ifc) == self:ifname())
+end
+
+netmod:register_pattern_virtual("^pppossh%-%w")