summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-29 13:04:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-29 13:04:44 +0000
commitec5487649e426957370a1dc30aacd32fb57ad691 (patch)
tree3ed626176212d926c3ba246082484a7bcdc2efdd
parentea1fc49a7f97f805225057bdc65a3154ed5618c5 (diff)
[PATCH] nixio HAS_SHADOW test link error
The nixio library can mistakenly build without shadow password support due to the compile-time test failing. Because the test for HAS_SHADOW in the nixio Makefile uses the default CC flags, the test may attempt to cross-compile with different VFP abi than libc does and will therefore not link. Passing CCFLAGS on the command line builds the test correctly and will enable HAS_SHADOW if available.
-rw-r--r--libs/nixio/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/libs/nixio/Makefile b/libs/nixio/Makefile
index 24ccb0175..49ba3ff22 100644
--- a/libs/nixio/Makefile
+++ b/libs/nixio/Makefile
@@ -10,7 +10,7 @@ AXTLS_VERSION = 1.2.1
AXTLS_DIR = axTLS
AXTLS_FILE = $(AXTLS_DIR)-$(AXTLS_VERSION).tar.gz
#NIXIO_TLS ?= openssl
-NIXIO_SHADOW ?= $(shell echo 'int main(void){ return !getspnam("root"); }' | $(CC) -include shadow.h -xc -o/dev/null - 2>/dev/null && echo yes)
+NIXIO_SHADOW ?= $(shell echo 'int main(void){ return !getspnam("root"); }' | $(CC) $(CFLAGS) -include shadow.h -xc -o/dev/null - 2>/dev/null && echo yes)
NIXIO_SO = nixio.so
NIXIO_LDFLAGS =