summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-28 22:29:03 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-28 22:29:03 +0100
commitd1c1423eba88005445378eb9bf2fc774e4c128dc (patch)
treed932916c474415a5d89992fece47849636147728
parent8464b98bb440fabdb4e7fdca12f7a79915d137be (diff)
build: remove *.luadoc files before packaging
-rw-r--r--luci.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/luci.mk b/luci.mk
index 0aba5c5ae..ab09f0f4f 100644
--- a/luci.mk
+++ b/luci.mk
@@ -147,6 +147,7 @@ define Package/$(PKG_NAME)/install
if [ -d $(PKG_BUILD_DIR)/luasrc ]; then \
$(INSTALL_DIR) $(1)$(LUCI_LIBRARYDIR); \
cp -pR $(PKG_BUILD_DIR)/luasrc/* $(1)$(LUCI_LIBRARYDIR)/; \
+ $(FIND) $(1)$(LUCI_LIBRARYDIR)/ -type f -name '*.luadoc' | $(XARGS) rm; \
$(if $(CONFIG_LUCI_SRCDIET),$(call SrcDiet,$(1)$(LUCI_LIBRARYDIR)/),true); \
else true; fi
if [ -d $(PKG_BUILD_DIR)/htdocs ]; then \