summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-08-05 16:10:47 +0000
committerSteven Barth <steven@midlink.org>2008-08-05 16:10:47 +0000
commitab7bda0b891432700481a9cfd4a987522a20dfb4 (patch)
treec4c44dc9e43cedaebcf1847a706e9b8018b758af
parent0181d2dee7652e710d8a0ac5048406b61f827483 (diff)
Fixed OpenWRT Makefile, mark Freifunk packages as broken
-rw-r--r--contrib/package/luci/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 90a543522..e3a0ea85a 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -61,8 +61,8 @@ endef
define Package/luci/fftemplate
$(call Package/luci/libtemplate)
- SUBMENU:=LuCI Freifunk Support (GERMAN ONLY)
- DEPENDS:=+luci-mod-freifunk
+ SUBMENU:=LuCI Freifunk Support (CURRENTLY BROKEN)
+ DEPENDS:=+luci-mod-freifunk @BROKEN
endef
define Package/luci/httpdtemplate
@@ -325,7 +325,7 @@ endef
define Package/luci-mod-freifunk
$(call Package/luci/fftemplate)
- DEPENDS:=+luci-admin-full
+ DEPENDS:=+luci-admin-full @BROKEN
TITLE:=LuCI Freifunk module
endef
@@ -365,7 +365,7 @@ endef
define Package/luci-app-olsr
$(call Package/luci/webtemplate)
- DEPENDS+=+luci-admin-full +olsrd-mod-txtinfo
+ DEPENDS+=+luci-admin-full +olsrd +olsrd-mod-txtinfo
TITLE:=OLSR configuration and status module
endef
@@ -387,7 +387,7 @@ endef
define Package/luci-app-splash
$(call Package/luci/fftemplate)
- DEPENDS+=+luasocket +iptables-mod-nat +iptables-mod-ipopt
+ DEPENDS+=+luasocket +firewall
TITLE:=Freifunk DHCP-Splash application
endef
@@ -481,7 +481,7 @@ endef
### Themes ###
define Package/luci-theme-fledermaus
$(call Package/luci/fftemplate)
- DEPENDS:=+luci-web
+ DEPENDS:=+luci-web @BROKEN
TITLE:=Fledermaus Theme
endef