summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-03-13 10:21:02 +0200
committerGitHub <noreply@github.com>2017-03-13 10:21:02 +0200
commit9779d5395c7e653aac32c173c49e27e5777a2c1d (patch)
tree6ff4aa9377669c9cbdeb289a5f4365096a283ad9
parent4c10d29ddcf3473bec34fab2b15c8ce017d6e8a5 (diff)
parente86438fa76932e348a347b18e247b0ed806628db (diff)
Merge pull request #1065 from stangri/luci-app-vpnbypass
luci-app-vpnbypass: updated service start/enable logic.
-rw-r--r--applications/luci-app-vpnbypass/Makefile3
-rw-r--r--applications/luci-app-vpnbypass/luasrc/model/cbi/vpnbypass.lua14
-rw-r--r--applications/luci-app-vpnbypass/po/templates/vpnbypass.pot2
3 files changed, 10 insertions, 9 deletions
diff --git a/applications/luci-app-vpnbypass/Makefile b/applications/luci-app-vpnbypass/Makefile
index e26fe273c..0ca74ae38 100644
--- a/applications/luci-app-vpnbypass/Makefile
+++ b/applications/luci-app-vpnbypass/Makefile
@@ -9,7 +9,8 @@ PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
LUCI_TITLE:=VPN Bypass Web UI
LUCI_DEPENDS:=+vpnbypass
LUCI_PKGARCH:=all
+PKG_RELEASE:=1
include ../../luci.mk
-# call BuildPackage - OpenWrt buildroot signature \ No newline at end of file
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/applications/luci-app-vpnbypass/luasrc/model/cbi/vpnbypass.lua b/applications/luci-app-vpnbypass/luasrc/model/cbi/vpnbypass.lua
index b50519463..b35a8e4e0 100644
--- a/applications/luci-app-vpnbypass/luasrc/model/cbi/vpnbypass.lua
+++ b/applications/luci-app-vpnbypass/luasrc/model/cbi/vpnbypass.lua
@@ -4,11 +4,11 @@ m = Map("vpnbypass", translate("VPN Bypass Settings"))
s = m:section(NamedSection, "config", "vpnbypass")
-- General options
-e = s:option(Flag, "enabled", translate("Enable VPN Bypass"))
+e = s:option(Flag, "enabled", translate("Enable/start service"))
e.rmempty = false
function e.cfgvalue(self, section)
- return luci.sys.init.enabled("vpnbypass") and self.enabled or self.disabled
+ return self.map:get(section, "enabled") == "1" and luci.sys.init.enabled("vpnbypass") and self.enabled or self.disabled
end
function e.write(self, section, value)
@@ -17,35 +17,35 @@ function e.write(self, section, value)
luci.sys.call("/etc/init.d/vpnbypass start >/dev/null")
else
luci.sys.call("/etc/init.d/vpnbypass stop >/dev/null")
- luci.sys.call("/etc/init.d/vpnbypass disable >/dev/null")
end
+ return Flag.write(self, section, value)
end
-- Local Ports
p1 = s:option(DynamicList, "localport", translate("Local Ports to Bypass"), translate("Local ports to trigger VPN Bypass"))
p1.datatype = "portrange"
-p1.placeholder = "0-65535"
+-- p1.placeholder = "0-65535"
p1.addremove = false
p1.optional = false
-- Remote Ports
p2 = s:option(DynamicList, "remoteport", translate("Remote Ports to Bypass"), translate("Remote ports to trigger VPN Bypass"))
p2.datatype = "portrange"
-p2.placeholder = "0-65535"
+-- p2.placeholder = "0-65535"
p2.addremove = false
p2.optional = false
-- Local Subnets
r1 = s:option(DynamicList, "localsubnet", translate("Local IP Addresses to Bypass"), translate("Local IP addresses or subnets with direct internet access (outside of the VPN tunnel)"))
r1.datatype = "ip4addr"
-r1.placeholder = luci.ip.new(uci.cursor():get("network", "lan", "ipaddr") .. "/" .. uci.cursor():get("network", "lan", "netmask"))
+-- r1.placeholder = luci.ip.new(uci.cursor():get("network", "lan", "ipaddr") .. "/" .. uci.cursor():get("network", "lan", "netmask"))
r1.addremove = false
r1.optional = false
-- Remote Subnets
r2 = s:option(DynamicList, "remotesubnet", translate("Remote IP Addresses to Bypass"), translate("Remote IP addresses or subnets which will be accessed directly (outside of the VPN tunnel)"))
r2.datatype = "ip4addr"
-r2.placeholder = "0.0.0.0/0"
+-- r2.placeholder = "0.0.0.0/0"
r2.addremove = false
r2.optional = false
diff --git a/applications/luci-app-vpnbypass/po/templates/vpnbypass.pot b/applications/luci-app-vpnbypass/po/templates/vpnbypass.pot
index 4322e1936..fd92b5e8a 100644
--- a/applications/luci-app-vpnbypass/po/templates/vpnbypass.pot
+++ b/applications/luci-app-vpnbypass/po/templates/vpnbypass.pot
@@ -7,7 +7,7 @@ msgstr ""
msgid "Domains to be accessed directly (outside of the VPN tunnel), see"
msgstr ""
-msgid "Enable VPN Bypass"
+msgid "Enable/start service"
msgstr ""
msgid "Local IP Addresses to Bypass"