summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-29 06:25:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-29 06:25:56 +0000
commit7a3715c5c576c5b64884bca7802f9ddd04c4fe72 (patch)
treee39f19113e9fffd2a45a7ed501415d8258d368ac
parent5a97114a8aa15be5cc4354da15415c7f7eedd2a1 (diff)
trunk/contrib: use local checkout in Makefile to determine latest revision
-rw-r--r--contrib/package/luci/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 5795b4da3..5fd6f4cc3 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -14,7 +14,7 @@ ifeq ($(USELOCAL),1)
else
PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
ifeq ($(DUMP),)
- PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Revision: //p')
+ PKG_REV:=$(shell LC_ALL=C svn info $(CURDIR) | sed -ne's/^Revision: //p')
PKG_VERSION:=0.9+svn$(PKG_REV)
endif
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)