summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-06-17 16:19:48 +0300
committerGitHub <noreply@github.com>2018-06-17 16:19:48 +0300
commit52de52e3e9d2da30d8905c2d0db8856353a9e7ab (patch)
tree4b3c56e6f4823fcceb2ce11d0ebc3694fa9dd6fd
parent24fb852054de609373648d810fa8e99cb8b40099 (diff)
parent0a6ad23f2ea124a2c0733b897baec054a530c45d (diff)
Merge pull request #1889 from Ansuel/lucnginx
luci-nginx: add nginx support file
-rw-r--r--collections/luci-nginx/Makefile2
-rw-r--r--collections/luci-ssl-nginx/Makefile2
-rw-r--r--collections/luci-ssl-openssl-nginx/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/collections/luci-nginx/Makefile b/collections/luci-nginx/Makefile
index 2d7de3899..7d14b1df7 100644
--- a/collections/luci-nginx/Makefile
+++ b/collections/luci-nginx/Makefile
@@ -12,7 +12,7 @@ LUCI_BASENAME:=nginx
LUCI_TITLE:=LuCI interface with Nginx as Webserver
LUCI_DESCRIPTION:=Standard OpenWrt set including full admin with ppp support and the default Bootstrap theme
LUCI_DEPENDS:= \
- +nginx +luci-mod-admin-full +luci-theme-bootstrap \
+ +nginx +nginx-mod-luci +luci-mod-admin-full +luci-theme-bootstrap \
+luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+rpcd-mod-rrdns
diff --git a/collections/luci-ssl-nginx/Makefile b/collections/luci-ssl-nginx/Makefile
index 45ae8b21d..d7ff49a7a 100644
--- a/collections/luci-ssl-nginx/Makefile
+++ b/collections/luci-ssl-nginx/Makefile
@@ -10,7 +10,7 @@ LUCI_TYPE:=col
LUCI_BASENAME:=ssl
LUCI_TITLE:=LuCI with HTTPS support (mbedTLS as SSL backend)
-LUCI_DEPENDS:=+luci-nginx +libustream-mbedtls +px5g
+LUCI_DEPENDS:=+luci-nginx +nginx-mod-luci-ssl +libustream-mbedtls +px5g
PKG_LICENSE:=Apache-2.0
diff --git a/collections/luci-ssl-openssl-nginx/Makefile b/collections/luci-ssl-openssl-nginx/Makefile
index f0e9b31c8..51096471e 100644
--- a/collections/luci-ssl-openssl-nginx/Makefile
+++ b/collections/luci-ssl-openssl-nginx/Makefile
@@ -14,7 +14,7 @@ LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
-LUCI_DEPENDS:=+luci-nginx +libustream-openssl +openssl-util
+LUCI_DEPENDS:=+luci-nginx +nginx-mod-luci-ssl +libustream-openssl +openssl-util
include ../../luci.mk