summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-12 08:45:05 +0000
committerSteven Barth <steven@midlink.org>2008-06-12 08:45:05 +0000
commitfd76e7f7fe774801693e0ca44007c9ea55fd282b (patch)
tree439ed17146dfa91e1c2494a0536c8e02947f37e8
parentb8430dcff704319f01279f1c399af4faf9cb9cb2 (diff)
* Fixed cross compiling
-rw-r--r--contrib/package/luci/Makefile4
-rw-r--r--libs/sgi-webuci/Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index af662f8cb..a059d0cfc 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -450,7 +450,9 @@ ifneq ($(CONFIG_PACKAGE_luci-i18n-english),)
endif
-MAKE_FLAGS += MODULES="$(PKG_SELECTED_MODULES)" LUA_TARGET="$(LUA_TARGET)" CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" LDFLAGS="$(TARGET_LDFLAGS)"
+MAKE_FLAGS += MODULES="$(PKG_SELECTED_MODULES)" LUA_TARGET="$(LUA_TARGET)" \
+CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" LDFLAGS="$(TARGET_LDFLAGS)" \
+CFOPTS="$(TARGET_CONFIGURE_OPTS)"
$(eval $(call BuildPackage,luci-core))
diff --git a/libs/sgi-webuci/Makefile b/libs/sgi-webuci/Makefile
index 656db032e..6758a2cbe 100644
--- a/libs/sgi-webuci/Makefile
+++ b/libs/sgi-webuci/Makefile
@@ -32,7 +32,7 @@ $(BOA_DIR)/.patched: $(BOA_DIR)/.prepared $(BOA_PATCHDIR)/series
touch $@
$(BOA_DIR)/.configured: $(BOA_DIR)/.patched
- (cd $(BOA_DIR); ./configure --disable-debug --disable-gunzip)
+ (cd $(BOA_DIR); ./configure --disable-debug --disable-gunzip $(CFOPTS))
touch $@
boa-compile: $(BOA_DIR)/.configured