summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-02-16 17:43:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-02-16 17:43:43 +0000
commitcb0e1804484cc3debd5e6ea8b7e2344ac7b9bd47 (patch)
tree057b2abf1ab7b0c2d356a320de973b946eae6653
parent695361877cd094b1d8d15f3f4d8018eef2bc7b03 (diff)
contrib/package: make luci-app-statistics depend on a few collectd plugins
applications/luci-statistics: implement a workaround for broken permissions on /tmp
-rwxr-xr-xapplications/luci-statistics/root/etc/init.d/luci_statistics15
-rw-r--r--contrib/package/luci/Makefile6
2 files changed, 14 insertions, 7 deletions
diff --git a/applications/luci-statistics/root/etc/init.d/luci_statistics b/applications/luci-statistics/root/etc/init.d/luci_statistics
index e4da1d5b1..21ed41ead 100755
--- a/applications/luci-statistics/root/etc/init.d/luci_statistics
+++ b/applications/luci-statistics/root/etc/init.d/luci_statistics
@@ -18,14 +18,17 @@ start() {
ln -s ${imagepath:-/tmp/rrdimg}/ /www/rrdimg
fi
- ### flush LuCI index cache
- test -f /var/luci-indexcache && rm /var/luci-indexcache
+ ### flush LuCI index cache
+ test -f /var/luci-indexcache && rm /var/luci-indexcache
+
+ ### workaround broken permissions on /tmp
+ chmod 1777 /tmp
}
restart() {
- ### regenerate config / prepare environment
- start
+ ### regenerate config / prepare environment
+ start
- ### restart collectd
- /etc/init.d/collectd restart
+ ### restart collectd
+ /etc/init.d/collectd restart
}
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 12aca229c..cebbf99c1 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -415,7 +415,11 @@ endef
define Package/luci-app-statistics
$(call Package/luci/webtemplate)
DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
- +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 +PACKAGE_luci-app-statistics:rrdtool1
+ +PACKAGE_luci-app-statistics:rrdtool1 \
+ +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 \
+ +PACKAGE_luci-app-statistics:collectd-mod-wireless \
+ +PACKAGE_luci-app-statistics:collectd-mod-interfaces \
+ +PACKAGE_luci-app-statistics:collectd-mod-load
TITLE:=LuCI Statistics Application
endef