summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-16 09:32:43 +0000
committerSteven Barth <steven@midlink.org>2008-04-16 09:32:43 +0000
commit69bc3fad1f0a49427a06cec47fe6a2b8b07969b8 (patch)
tree02e3130eb46aa7bc171638455b7bb62132e7ccd5
parent5ae7b3ee9a6928238f4cd424701b9e969dd68ee8 (diff)
* Reintroduced public pages
* Automatically replace nil template values with ''
-rw-r--r--contrib/package/ffluci/Makefile2
-rw-r--r--core/contrib/uci/freifunk16
-rw-r--r--core/contrib/uci/luci21
-rw-r--r--core/src/ffluci/template.lua2
-rw-r--r--core/src/ffluci/view/cbi/dvalue.htm2
-rw-r--r--core/src/ffluci/view/cbi/value.htm2
-rw-r--r--module/admin-core/src/model/cbi/admin_index/contact.lua2
-rw-r--r--module/admin-core/src/view/admin_system/editor.htm4
-rw-r--r--module/admin-core/src/view/admin_system/ipkg.htm2
-rw-r--r--module/admin-core/src/view/admin_system/packages.htm6
-rw-r--r--module/admin-core/src/view/admin_system/sshkeys.htm2
-rw-r--r--module/public-core/src/view/public_index/contact.htm15
-rw-r--r--module/public-core/src/view/public_index/index.htm12
13 files changed, 51 insertions, 37 deletions
diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile
index 2230145fb..67f83d0db 100644
--- a/contrib/package/ffluci/Makefile
+++ b/contrib/package/ffluci/Makefile
@@ -45,7 +45,7 @@ define Package/ffluci/install
$(INSTALL_DIR) $(1)/sbin
$(CP) $(PKG_BUILD_DIR)/core/dist/* $(1)/usr/lib/lua/ -R
- $(CP) $(PKG_BUILD_DIR)/core/contrib/uci/luci $(1)/etc/config/luci
+ $(CP) $(PKG_BUILD_DIR)/core/contrib/uci/* $(1)/etc/config/luci
$(INSTALL_BIN) $(PKG_BUILD_DIR)/core/contrib/ffluci $(1)/www/cgi-bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/core/contrib/ffluci-upload $(1)/www/cgi-bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/core/contrib/index.cgi $(1)/www/cgi-bin
diff --git a/core/contrib/uci/freifunk b/core/contrib/uci/freifunk
new file mode 100644
index 000000000..128267d04
--- /dev/null
+++ b/core/contrib/uci/freifunk
@@ -0,0 +1,16 @@
+config public contact
+ option nickname
+ option name
+ option mail
+ option phone
+ option location
+ option geo
+ option note
+
+config public community
+ option name "Freifunk Halle"
+ option homepage http://halle.freifunk.net
+ option essid halle.freifunk.net
+ option bssid 02:CA:FF:EE:BA:BE
+ option realm netz.freifunk-halle.net
+ option pool 104.62.0.0/16 \ No newline at end of file
diff --git a/core/contrib/uci/luci b/core/contrib/uci/luci
index e54d74717..7cc08215a 100644
--- a/core/contrib/uci/luci
+++ b/core/contrib/uci/luci
@@ -6,22 +6,13 @@ config core category_privileges
option public nobody:nogroup
config extern flash_keep
- option uci "/etc/config"
+ option uci "/etc/config"
option dropbear "/etc/dropbear"
- option openvpn "/etc/openvpn"
- option passwd "/etc/passwd"
- option ipkg "/etc/ipkg.conf"
- option httpd "/etc/httpd.conf"
- option firewall "/etc/firewall.user"
-
-config public contact
- option nickname
- option name
- option mail
- option phone
- option location
- option geo
- option note
+ option openvpn "/etc/openvpn"
+ option passwd "/etc/passwd"
+ option ipkg "/etc/ipkg.conf"
+ option httpd "/etc/httpd.conf"
+ option firewall "/etc/firewall.user"
config event uci_oncommit
option network "/etc/init.d/network restart"
diff --git a/core/src/ffluci/template.lua b/core/src/ffluci/template.lua
index 502013684..797e9d127 100644
--- a/core/src/ffluci/template.lua
+++ b/core/src/ffluci/template.lua
@@ -95,7 +95,7 @@ function compile(template)
local r_include = "')\ninclude('%s')\nwrite('"
local r_i18n = "'..translate('%1','%2')..'"
local r_uci = "'..config('%1','%2','%3')..'"
- local r_pexec = "'..%s..'"
+ local r_pexec = "'..(%s or '')..'"
local r_exec = "')\n%s\nwrite('"
-- Parse the expressions
diff --git a/core/src/ffluci/view/cbi/dvalue.htm b/core/src/ffluci/view/cbi/dvalue.htm
index 178f2e16a..f54667def 100644
--- a/core/src/ffluci/view/cbi/dvalue.htm
+++ b/core/src/ffluci/view/cbi/dvalue.htm
@@ -6,7 +6,7 @@
<%=self.value%>
<% end
else %>
- <%=(self:cfgvalue(section) or "")%>
+ <%=self:cfgvalue(section)%>
<% end %>
&nbsp;
<%+cbi/valuefooter%>
diff --git a/core/src/ffluci/view/cbi/value.htm b/core/src/ffluci/view/cbi/value.htm
index 61033a0f5..31bf38f77 100644
--- a/core/src/ffluci/view/cbi/value.htm
+++ b/core/src/ffluci/view/cbi/value.htm
@@ -1,3 +1,3 @@
<%+cbi/valueheader%>
- <input type="text" onchange="cbi_d_update(this.id)" <% if self.size then %>size="<%=self.size%>" <% end %><% if self.maxlength then %>maxlength="<%=self.maxlength%>" <% end %>name="cbid.<%=self.config.."."..section.."."..self.option%>" id="cbid.<%=self.config.."."..section.."."..self.option%>" value="<%=(self:cfgvalue(section) or "")%>" />
+ <input type="text" onchange="cbi_d_update(this.id)" <% if self.size then %>size="<%=self.size%>" <% end %><% if self.maxlength then %>maxlength="<%=self.maxlength%>" <% end %>name="cbid.<%=self.config.."."..section.."."..self.option%>" id="cbid.<%=self.config.."."..section.."."..self.option%>" value="<%=self:cfgvalue(section)%>" />
<%+cbi/valuefooter%>
diff --git a/module/admin-core/src/model/cbi/admin_index/contact.lua b/module/admin-core/src/model/cbi/admin_index/contact.lua
index 187db9f3c..ecb4bedd7 100644
--- a/module/admin-core/src/model/cbi/admin_index/contact.lua
+++ b/module/admin-core/src/model/cbi/admin_index/contact.lua
@@ -1,5 +1,5 @@
-- Todo: Translate
-m = Map("luci", translate("contact", "Kontakt"), translate("contact1", [[Diese Daten sind
+m = Map("freifunk", translate("contact", "Kontakt"), translate("contact1", [[Diese Daten sind
auf der öffentlichen Kontaktseite sichtbar. Bitte gib an, wie man dich am besten kontaktieren kann.
Diese Informationen sollten nach der Picopeering Vereinbarung mindestens deine E-Mail-Adresse enthalten.
Damit dein Knoten durch Topographieprogramme erfasst werden kann, gib bitte deine Geokoordinaten oder
diff --git a/module/admin-core/src/view/admin_system/editor.htm b/module/admin-core/src/view/admin_system/editor.htm
index 0215c91df..ef3e0d8ab 100644
--- a/module/admin-core/src/view/admin_system/editor.htm
+++ b/module/admin-core/src/view/admin_system/editor.htm
@@ -1,10 +1,10 @@
<%+header%>
<h1><%:texteditor Texteditor%></h1>
<form method="post" action="<%=controller%>/admin/system/editor">
-<div><%:file Datei%>: <input type="text" name="file" size="30" value="<%=(fn or '')%>" />
+<div><%:file Datei%>: <input type="text" name="file" size="30" value="<%=fn%>" />
<% if msg then %><span class="error"><%:error Fehler%>: <%=msg%></span><% end %></div>
<br />
-<div><textarea style="width: 100%" rows="20" name="data"><%=(cnt or '')%></textarea></div>
+<div><textarea style="width: 100%" rows="20" name="data"><%=cnt%></textarea></div>
<br />
<div>
<input type="submit" value="<%:save Speichern%>" />
diff --git a/module/admin-core/src/view/admin_system/ipkg.htm b/module/admin-core/src/view/admin_system/ipkg.htm
index bbe7f3bc6..c1f6ad0be 100644
--- a/module/admin-core/src/view/admin_system/ipkg.htm
+++ b/module/admin-core/src/view/admin_system/ipkg.htm
@@ -11,7 +11,7 @@
<form method="post" action="<%=controller%>/admin/system/ipkg">
<fieldset class="cbi-section-node">
- <div><textarea style="width: 100%" rows="10" name="data"><%=(cnt or '')%></textarea></div>
+ <div><textarea style="width: 100%" rows="10" name="data"><%=cnt%></textarea></div>
<br />
<div>
<input type="submit" value="<%:save Speichern%>" />
diff --git a/module/admin-core/src/view/admin_system/packages.htm b/module/admin-core/src/view/admin_system/packages.htm
index d9cdb4dd0..52da37040 100644
--- a/module/admin-core/src/view/admin_system/packages.htm
+++ b/module/admin-core/src/view/admin_system/packages.htm
@@ -43,7 +43,7 @@
<div>
<span class="bold"><%:filter Filter%>:</span>
- <input type="text" name="query" size="20" value="<%=(query or '')%>" />
+ <input type="text" name="query" size="20" value="<%=query%>" />
<input type="submit" name="search" value="<%:packages_search Paket suchen%>" />
<input type="submit" name="submit" value="<%:packages_do Aktionen ausführen%>" />
</div>
@@ -63,10 +63,10 @@
<% for k, pkg in pairs(pkgs) do %>
<tr>
<td><%=pkg.Package%></td>
- <td><%=(pkg.Version or '')%></td>
+ <td><%=pkg.Version%></td>
<td><% if not pkg.Status or not pkg.Status.installed then %><input type="checkbox" name="install.<%=pkg.Package%>" value="1" /><% else %><%:installed installiert%><% end %></td>
<td><% if pkg.Status and pkg.Status.installed then %><input type="checkbox" name="remove.<%=pkg.Package%>" value="1" /><% else %><%:notinstalled nicht installiert%><% end %></td>
- <td><%=(pkg.Description or '')%></td>
+ <td><%=pkg.Description%></td>
</tr>
<% end %>
</table>
diff --git a/module/admin-core/src/view/admin_system/sshkeys.htm b/module/admin-core/src/view/admin_system/sshkeys.htm
index 1e1cc24ce..9cf91f998 100644
--- a/module/admin-core/src/view/admin_system/sshkeys.htm
+++ b/module/admin-core/src/view/admin_system/sshkeys.htm
@@ -11,7 +11,7 @@
<form method="post" action="<%=controller%>/admin/system/sshkeys">
<fieldset class="cbi-section-node">
- <div><textarea style="width: 100%" rows="10" name="data"><%=(cnt or '')%></textarea></div>
+ <div><textarea style="width: 100%" rows="10" name="data"><%=cnt%></textarea></div>
<br />
<div>
<input type="submit" value="<%:save Speichern%>" />
diff --git a/module/public-core/src/view/public_index/contact.htm b/module/public-core/src/view/public_index/contact.htm
index ded0a94af..e5aee1906 100644
--- a/module/public-core/src/view/public_index/contact.htm
+++ b/module/public-core/src/view/public_index/contact.htm
@@ -1,12 +1,13 @@
<%+header%>
+<% local contact = ffluci.model.uci.show("freifunk", "contact").freifunk.contact %>
<h1><%:contact Kontakt%></h1>
<table class="contact">
- <tr><th><%:nickname Pseudonym%>:</th><td><%~luci.contact.nickname%></td></tr>
- <tr><th><%:name Name%>:</th><td><%~luci.contact.name%></td></tr>
- <tr><th><%:mail E-Mail%>:</th><td><%~luci.contact.mail%></td></tr>
- <tr><th><%:phone Telefon%>:</th><td><%~luci.contact.phone%></td></tr>
- <tr><th><%:location Standort%>:</th><td><%~luci.contact.location%></td></tr>
- <tr><th><%:geocoord Geokoordinaten%>:</th><td><%~luci.contact.geo%></td></tr>
- <tr><th><%:note Notiz%>:</th><td><%~luci.contact.note%></td></tr>
+ <tr><th style="text-align: right"><%:nickname Pseudonym%>:</th><td><%=contact.nickname%></td></tr>
+ <tr><th style="text-align: right"><%:name Name%>:</th><td><%=contact.name%></td></tr>
+ <tr><th style="text-align: right"><%:mail E-Mail%>:</th><td><%=contact.mail%></td></tr>
+ <tr><th style="text-align: right"><%:phone Telefon%>:</th><td><%=contact.phone%></td></tr>
+ <tr><th style="text-align: right"><%:location Standort%>:</th><td><%=contact.location%></td></tr>
+ <tr><th style="text-align: right"><%:geocoord Geokoordinaten%>:</th><td><%=contact.geo%></td></tr>
+ <tr><th style="text-align: right"><%:note Notiz%>:</th><td><%=contact.note%></td></tr>
</table>
<%+footer%> \ No newline at end of file
diff --git a/module/public-core/src/view/public_index/index.htm b/module/public-core/src/view/public_index/index.htm
index 1f06e344c..838bf02ee 100644
--- a/module/public-core/src/view/public_index/index.htm
+++ b/module/public-core/src/view/public_index/index.htm
@@ -1,5 +1,11 @@
<%+header%>
-<h1><%:hello Hallo!%></h1>
-<p><%:admin1 Dies ist der Administrationsbereich. %>
-<p><em>ToDo: Intelligenter Einleitungstext</em></p>
+<% local ff = ffluci.model.uci.show("freifunk").freifunk %>
+<h1><%:hellonet Hallo und willkommen im Netz von%> <%=ff.community.name%>!</h1>
+<p><%:public1 Wir sind eine Initiative zur Schaffung eines freien, offenen und unabhängigen Funknetzwerks auf WLAN-Basis.%><br />
+<%:public2 Dies ist der Zugangspunkt %><%=ffluci.sys.hostname()%>. <%:public3 Er wird betrieben von %>
+<a href="<%=controller%>/public/index/contact"><%=ff.contact.nickname%></a>.</p>
+<p><%:public4 Weitere Informationen zur globalen Freifunkinitiative findest du unter%> <a href="http://freifunk.net">Freifunk.net</a>.<br />
+<%:public5 Hast du Interesse an diesem Projekt, dann wende dich an deine lokale Gemeinschaft%> <a href="<%=ff.community.homepage%>"><%=ff.community.name%></a>.</p>
+<p><strong><%:note Hinweis%></strong>:<%:public6 Der Internetzugang über das experimentelle Freifunknetz ist an technische und organisatorische Bedingungen geknüpft und deshalb möglicherweise
+nicht (immer) gewährleistet.%></p>
<%+footer%> \ No newline at end of file