summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-10-03 21:11:23 +0300
committerGitHub <noreply@github.com>2016-10-03 21:11:23 +0300
commit4a246820b1d12e8aed5b443d9f57da57ac3bc27b (patch)
tree78d4728cc29e43225706724b8f5af10619640afb
parent87a7570690f7aeffb1aff01f320973c9acb668d3 (diff)
parent67de9f4bca4b578885970814023a88f128d1ba60 (diff)
Merge pull request #807 from hnyman/ssl-openssl
luci-ssl-openssl: Provide OpenSSL-based LuCI collection
-rw-r--r--collections/luci-ssl-openssl/Makefile19
-rw-r--r--collections/luci-ssl/Makefile4
2 files changed, 21 insertions, 2 deletions
diff --git a/collections/luci-ssl-openssl/Makefile b/collections/luci-ssl-openssl/Makefile
new file mode 100644
index 000000000..37442a37d
--- /dev/null
+++ b/collections/luci-ssl-openssl/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2016 The LuCI Team
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl-openssl
+
+LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ Note: px5g still requires libpolarssl
+LUCI_DEPENDS:=+luci +libustream-openssl +px5g
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
diff --git a/collections/luci-ssl/Makefile b/collections/luci-ssl/Makefile
index 07c9c5068..f25e3112d 100644
--- a/collections/luci-ssl/Makefile
+++ b/collections/luci-ssl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+# Copyright (C) 2008-2016 The LuCI Team
#
# This is free software, licensed under the Apache License, Version 2.0 .
#
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
LUCI_TYPE:=col
LUCI_BASENAME:=ssl
-LUCI_TITLE:=Standard OpenWrt set with HTTPS support
+LUCI_TITLE:=LuCI with HTTPS support (PolarSSL as SSL backend)
LUCI_DEPENDS:=+luci +libustream-polarssl +px5g
include ../../luci.mk