summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-10-02 13:52:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-10-02 13:52:28 +0000
commit3f372dd416348af57905e8f3ef72aefe0012a250 (patch)
tree2a597d2e8b1f10d55ec9de3a0d0efb5e29fbbcab
parentb5de7f81384b38737fbdecfe6179fe5905fa73d8 (diff)
* luci/applications: add hd-idle application, thanks Yanira
-rw-r--r--applications/luci-hd_idle/Makefile2
-rw-r--r--applications/luci-hd_idle/ipkg/postinst4
-rw-r--r--applications/luci-hd_idle/luasrc/controller/hd_idle.lua28
-rw-r--r--applications/luci-hd_idle/luasrc/i18n/hd_idle.de.lua7
-rw-r--r--applications/luci-hd_idle/luasrc/i18n/hd_idle.de.xml13
-rw-r--r--applications/luci-hd_idle/luasrc/i18n/hd_idle.en.lua7
-rw-r--r--applications/luci-hd_idle/luasrc/i18n/hd_idle.en.xml13
-rw-r--r--applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua36
-rw-r--r--applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle7
-rw-r--r--contrib/package/luci/Makefile14
10 files changed, 131 insertions, 0 deletions
diff --git a/applications/luci-hd_idle/Makefile b/applications/luci-hd_idle/Makefile
new file mode 100644
index 000000000..81a96f6a8
--- /dev/null
+++ b/applications/luci-hd_idle/Makefile
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk \ No newline at end of file
diff --git a/applications/luci-hd_idle/ipkg/postinst b/applications/luci-hd_idle/ipkg/postinst
new file mode 100644
index 000000000..4c3b4dca8
--- /dev/null
+++ b/applications/luci-hd_idle/ipkg/postinst
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+ ( . /etc/uci-defaults/luci-hd_idle ) && rm -f /etc/uci-defaults/luci-hd_idle
+}
diff --git a/applications/luci-hd_idle/luasrc/controller/hd_idle.lua b/applications/luci-hd_idle/luasrc/controller/hd_idle.lua
new file mode 100644
index 000000000..45d102cc1
--- /dev/null
+++ b/applications/luci-hd_idle/luasrc/controller/hd_idle.lua
@@ -0,0 +1,28 @@
+--[[
+
+LuCI hd-idle
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+module("luci.controller.hd_idle", package.seeall)
+
+function index()
+ require("luci.i18n")
+ luci.i18n.loadc("hd_idle")
+ if not luci.fs.isfile("/etc/config/hd-idle") then
+ return
+ end
+
+ local page = entry({"admin", "services", "hd_idle"}, cbi("hd_idle"), luci.i18n.translate("hd_idle", "hd-idle"), 60)
+ page.i18n = "hd_idle"
+ page.dependent = true
+end
diff --git a/applications/luci-hd_idle/luasrc/i18n/hd_idle.de.lua b/applications/luci-hd_idle/luasrc/i18n/hd_idle.de.lua
new file mode 100644
index 000000000..ca276ab4f
--- /dev/null
+++ b/applications/luci-hd_idle/luasrc/i18n/hd_idle.de.lua
@@ -0,0 +1,7 @@
+disk = 'Festplatte'
+enable_debug = 'Debug-Ausgaben aktivieren'
+hd_idle = 'hd-idle'
+hd_idle_desc = 'hd-idle ist ein Hilfsprogramm um externe Festplatten nach einer festgelegten Leerlaufzeit herunter zu fahren.'
+idle_time_interval = 'Leerlaufzeit'
+idle_time_unit = 'Leerlaufzeiteinheit'
+settings = 'Einstellungen'
diff --git a/applications/luci-hd_idle/luasrc/i18n/hd_idle.de.xml b/applications/luci-hd_idle/luasrc/i18n/hd_idle.de.xml
new file mode 100644
index 000000000..398df0074
--- /dev/null
+++ b/applications/luci-hd_idle/luasrc/i18n/hd_idle.de.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="utf-8"?>
+
+<i18n:msgs xmlns:i18n="http://luci.freifunk-halle.net/2008/i18n#" xmlns="http://www.w3.org/1999/xhtml">
+
+<i18n:msg xml:id="disk">Festplatte</i18n:msg>
+<i18n:msg xml:id="enable_debug">Debug-Ausgaben aktivieren</i18n:msg>
+<i18n:msg xml:id="hd_idle">hd-idle</i18n:msg>
+<i18n:msg xml:id="hd_idle_desc">hd-idle ist ein Hilfsprogramm um externe Festplatten nach einer festgelegten Leerlaufzeit herunter zu fahren.</i18n:msg>
+<i18n:msg xml:id="idle_time_interval">Leerlaufzeit</i18n:msg>
+<i18n:msg xml:id="idle_time_unit">Leerlaufzeiteinheit</i18n:msg>
+<i18n:msg xml:id="settings">Einstellungen</i18n:msg>
+
+</i18n:msgs>
diff --git a/applications/luci-hd_idle/luasrc/i18n/hd_idle.en.lua b/applications/luci-hd_idle/luasrc/i18n/hd_idle.en.lua
new file mode 100644
index 000000000..2ec778002
--- /dev/null
+++ b/applications/luci-hd_idle/luasrc/i18n/hd_idle.en.lua
@@ -0,0 +1,7 @@
+disk = 'Disk'
+enable_debug = 'Enable debug'
+hd_idle = 'hd-idle'
+hd_idle_desc = 'hd-idle is a utility program for spinning-down external disks after a period of idle time.'
+idle_time_interval = 'Idle-Time'
+idle_time_unit = 'Idle-Time unit'
+settings = 'Settings'
diff --git a/applications/luci-hd_idle/luasrc/i18n/hd_idle.en.xml b/applications/luci-hd_idle/luasrc/i18n/hd_idle.en.xml
new file mode 100644
index 000000000..7802a7826
--- /dev/null
+++ b/applications/luci-hd_idle/luasrc/i18n/hd_idle.en.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="utf-8"?>
+
+<i18n:msgs xmlns:i18n="http://luci.freifunk-halle.net/2008/i18n#" xmlns="http://www.w3.org/1999/xhtml">
+
+<i18n:msg xml:id="disk">Disk</i18n:msg>
+<i18n:msg xml:id="enable_debug">Enable debug</i18n:msg>
+<i18n:msg xml:id="hd_idle">hd-idle</i18n:msg>
+<i18n:msg xml:id="hd_idle_desc">hd-idle is a utility program for spinning-down external disks after a period of idle time.</i18n:msg>
+<i18n:msg xml:id="idle_time_interval">Idle-Time</i18n:msg>
+<i18n:msg xml:id="idle_time_unit">Idle-Time unit</i18n:msg>
+<i18n:msg xml:id="settings">Settings</i18n:msg>
+
+</i18n:msgs>
diff --git a/applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua b/applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua
new file mode 100644
index 000000000..32db2605e
--- /dev/null
+++ b/applications/luci-hd_idle/luasrc/model/cbi/hd_idle.lua
@@ -0,0 +1,36 @@
+--[[
+
+LuCI hd-idle
+(c) 2008 Yanira <forum-2008@email.de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+]]--
+
+m = Map("hd-idle", translate("hd_idle"), translate("hd_idle_desc"))
+
+s = m:section(TypedSection, "hd-idle", translate("settings"))
+s.addremove = true
+s.anonymous = true
+
+s:option(Flag, "enabled", translate("enabled", "Enable"))
+
+s:option(Value, "disk", translate("disk")).rmempty = true
+
+s:option(Value, "idle_time_interval", translate("idle_time_interval")).default = 10
+s.rmempty = true
+unit = s:option(ListValue, "idle_time_unit", translate("idle_time_unit"))
+unit.default = "minutes"
+unit:value("minutes", "min")
+unit:value("hours", "h")
+unit.rmempty = true
+
+s:option(Flag, "enable_debug", translate("enable_debug"))
+
+return m
diff --git a/applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle b/applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle
new file mode 100644
index 000000000..6a37176a3
--- /dev/null
+++ b/applications/luci-hd_idle/root/etc/uci-defaults/luci-hd_idle
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+uci batch <<-EOF
+ add ucitrack hd-idle
+ set ucitrack.@hd-idle[-1].init=hd-idle
+ commit ucitrack
+EOF
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 5806efe75..06bc35de1 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -484,6 +484,16 @@ define Package/luci-app-ushare/install
$(call Package/luci/install/template,$(1),applications/luci-ushare)
endef
+define Package/luci-app-hd_idle
+ $(call Package/luci/webtemplate)
+ DEPENDS+=+luci-admin-full +hd-idle
+ TITLE:=hd-idle
+endef
+
+define Package/luci-app-hd_idle/install
+ $(call Package/luci/install/template,$(1),applications/luci-hd_idle)
+endef
+
### Server Gateway Interfaces ###
@@ -713,6 +723,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-app-ushare),)
PKG_SELECTED_MODULES+=applications/luci-ushare
endif
+ifneq ($(CONFIG_PACKAGE_luci-app-hd_idle),)
+ PKG_SELECTED_MODULES+=applications/luci-hd_idle
+endif
ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -801,6 +814,7 @@ $(eval $(call BuildPackage,luci-app-samba))
$(eval $(call BuildPackage,luci-app-uvc_streamer))
$(eval $(call BuildPackage,luci-app-p910nd))
$(eval $(call BuildPackage,luci-app-ushare))
+$(eval $(call BuildPackage,luci-app-hd_idle))
$(eval $(call BuildPackage,luci-sgi-cgi))
$(eval $(call BuildPackage,luci-sgi-luci))