summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-04 00:34:30 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-04 00:34:30 +0200
commitf7639bcd6a2caf7cc0f03e85744906c577eefeab (patch)
tree7ee5b5e5ff28008a3e80deae974faa329792f238
parent4a246820b1d12e8aed5b443d9f57da57ac3bc27b (diff)
luci-base: fix luci-base host tool install on OpenWrt
OpenWrt doesn't provide an argument to Host/Install like LEDE does; use HOST_BUILD_PREFIX instead, which is available on both. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--modules/luci-base/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index 972a451c6..4fb278b56 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,9 +37,9 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(1)/bin
- $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
+ $(INSTALL_DIR) $(HOST_BUILD_PREFIX)/bin
+ $(INSTALL_BIN) src/po2lmo $(HOST_BUILD_PREFIX)/bin/po2lmo
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(HOST_BUILD_PREFIX)/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))