summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>2016-03-07 10:57:44 +0100
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>2016-03-07 10:57:44 +0100
commitd26bffefb360cf3b9f0698f48f18dbac083d65a2 (patch)
treed116635ccf548f65fba1c1c34d2aef8848c353b5
parentddc893ccc254e79b0869c709ada07f5ae232a0e3 (diff)
parente1fb9e579a69406f0c7c632792f9602de0609709 (diff)
Merge pull request #664 from chris5560/master
luci-app-ddns: fixes because uclient-fetch support "force ip version"
-rw-r--r--applications/luci-app-ddns/Makefile2
-rwxr-xr-xapplications/luci-app-ddns/luasrc/controller/ddns.lua4
-rw-r--r--applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua4
-rwxr-xr-xapplications/luci-app-ddns/luasrc/tools/ddns.lua2
-rw-r--r--applications/luci-app-ddns/po/de/ddns.po94
-rw-r--r--applications/luci-app-ddns/po/templates/ddns.pot86
6 files changed, 21 insertions, 171 deletions
diff --git a/applications/luci-app-ddns/Makefile b/applications/luci-app-ddns/Makefile
index 146560efa..2e5fc7639 100644
--- a/applications/luci-app-ddns/Makefile
+++ b/applications/luci-app-ddns/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
# Version == major.minor.patch
# increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.1
+PKG_VERSION:=2.4.2
# Release == build
# increase on changes of translation files
diff --git a/applications/luci-app-ddns/luasrc/controller/ddns.lua b/applications/luci-app-ddns/luasrc/controller/ddns.lua
index 7cfbc56a0..652c24438 100755
--- a/applications/luci-app-ddns/luasrc/controller/ddns.lua
+++ b/applications/luci-app-ddns/luasrc/controller/ddns.lua
@@ -18,11 +18,11 @@ local UTIL = require "luci.util"
local DDNS = require "luci.tools.ddns" -- ddns multiused functions
local srv_name = "ddns-scripts"
-local srv_ver_min = "2.6.0" -- minimum version of service required
+local srv_ver_min = "2.6.3" -- minimum version of service required
local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
local app_name = "luci-app-ddns"
local app_title = "Dynamic DNS"
-local app_version = "2.4.1-1"
+local app_version = "2.4.2-1"
function index()
local nxfs = require "nixio.fs" -- global definitions not available
diff --git a/applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua b/applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua
index 335bb01b2..3f5997463 100644
--- a/applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua
+++ b/applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua
@@ -112,9 +112,9 @@ if not DDNS.has_forceip then
translate("Force IP Version not supported") .. bold_off
local value = translate("BusyBox's nslookup and Wget do not support to specify " ..
"the IP version to use for communication with DDNS Provider!")
- if not (DDNS.has_wgetssl or DDNS.has_curl) then
+ if not (DDNS.has_wgetssl or DDNS.has_curl or DDNS.has_fetch) then
value = value .. "<br />- " ..
- translate("You should install GNU Wget with SSL (prefered) or cURL package.")
+ translate("You should install GNU Wget with SSL (prefered) or cURL or uclient-fetch package.")
end
if not (DDNS.has_bindhost or DDNS.has_hostip) then
value = value .. "<br />- " ..
diff --git a/applications/luci-app-ddns/luasrc/tools/ddns.lua b/applications/luci-app-ddns/luasrc/tools/ddns.lua
index 54791432b..b326cd120 100755
--- a/applications/luci-app-ddns/luasrc/tools/ddns.lua
+++ b/applications/luci-app-ddns/luasrc/tools/ddns.lua
@@ -29,7 +29,7 @@ has_nslookup = (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"
has_ipv6 = (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
has_ssl = (has_wgetssl or has_curlssl or (has_fetch and has_fetchssl))
has_proxy = (has_wgetssl or has_curlpxy or has_fetch or has_bbwget)
-has_forceip = ((has_wgetssl or has_curl) and (has_bindhost or has_hostip))
+has_forceip = ((has_wgetssl or has_curl or has_fetch) and (has_bindhost or has_hostip))
has_dnsserver = (has_bindhost or has_hostip or has_nslookup)
has_bindnet = (has_wgetssl or has_curl)
has_cacerts = _check_certs()
diff --git a/applications/luci-app-ddns/po/de/ddns.po b/applications/luci-app-ddns/po/de/ddns.po
index 065f22c74..1f69bd9ff 100644
--- a/applications/luci-app-ddns/po/de/ddns.po
+++ b/applications/luci-app-ddns/po/de/ddns.po
@@ -1,8 +1,8 @@
msgid ""
msgstr ""
-"Project-Id-Version: luci-app-ddns 2.4.0-1\n"
-"POT-Creation-Date: 2016-01-30 11:07+0100\n"
-"PO-Revision-Date: 2016-01-30 11:07+0100\n"
+"Project-Id-Version: luci-app-ddns 2.4.2-1\n"
+"POT-Creation-Date: 2016-02-29 20:55+0100\n"
+"PO-Revision-Date: 2016-02-29 20:58+0100\n"
"Last-Translator: Christian Schoenebeck <christian.schoenebeck@gmail.com>\n"
"Language-Team: \n"
"Language: de\n"
@@ -17,21 +17,12 @@ msgstr ""
msgid "&"
msgstr "&"
-msgid "-- custom --"
-msgstr "-- benutzerdefiniert --"
-
msgid "-- default --"
msgstr "-- Standard --"
-msgid "Advanced Settings"
-msgstr "Erweiterte Einstellungen"
-
msgid "Allow non-public IP's"
msgstr "Erlaube Nicht-öffentliche IPs"
-msgid "Applying changes"
-msgstr "Änderungen anwenden"
-
msgid "Basic Settings"
msgstr "Grundlegende Einstellungen"
@@ -83,15 +74,9 @@ msgstr "Anbieter wechseln"
msgid "Check Interval"
msgstr "Prüfinterval"
-msgid "Collecting data..."
-msgstr "Sammle Daten..."
-
msgid "Config error"
msgstr "Konfigurationsfehler"
-msgid "Configuration"
-msgstr "Einstellungen"
-
msgid ""
"Configure here the details for all Dynamic DNS services including this LuCI "
"application."
@@ -209,9 +194,6 @@ msgstr ""
"Das Verzeichnis enthält die PID und andere Statusinformationen aller "
"laufenden Konfigurationen."
-msgid "Disabled"
-msgstr "Deaktiviert"
-
msgid "Domain"
msgstr "Domäne"
@@ -228,12 +210,6 @@ msgstr ""
msgid "Enable secure communication with DDNS provider"
msgstr "Aktiviert sichere Kommunikation mit dem DDNS Anbieter"
-msgid "Enabled"
-msgstr "Aktiviert"
-
-msgid "Error"
-msgstr "Fehler"
-
msgid "Error Retry Counter"
msgstr "Wiederholungszähler bei Fehler"
@@ -243,9 +219,6 @@ msgstr "Wiederholungsintervall bei Fehler"
msgid "Event Network"
msgstr "Ereignis Netzwerk"
-msgid "File"
-msgstr "Datei"
-
msgid "File not found"
msgstr "Datei nicht gefunden"
@@ -294,9 +267,6 @@ msgstr ""
"GNU Wget verwendet die IP des gewählten Netzwerkes; cURL verwendet die "
"physikalische Schnittstelle."
-msgid "Global Settings"
-msgstr "Globale Einstellungen"
-
msgid "HTTPS not supported"
msgstr "HTTPS nicht unterstützt"
@@ -314,9 +284,6 @@ msgstr "IP-Adressquelle"
msgid "IP address version"
msgstr "IP-Adressversion"
-msgid "IPv4-Address"
-msgstr "IPv4-Adresse"
-
msgid "IPv6 address must be given in square brackets"
msgstr "Eine IPv6 Adresse muss in eckigen Klammern angegeben werden"
@@ -332,9 +299,6 @@ msgstr ""
msgid "IPv6 not supported"
msgstr "IPv6 nicht unterstützt"
-msgid "IPv6-Address"
-msgstr "IPv6-Adresse"
-
msgid "If both cURL and GNU Wget are installed, Wget is used by default."
msgstr "Wenn cURL und GNU Wget installiert sind, wird Wget verwendet."
@@ -363,9 +327,6 @@ msgstr ""
"In einigen Versionen von OpenWrt wurde cURL/libcurl ohne Proxy Unterstützung "
"compiliert."
-msgid "Info"
-msgstr "Informationen"
-
msgid ""
"Install ca-certificates package or needed certificates by hand into /etc/ssl/"
"certs default directory"
@@ -373,9 +334,6 @@ msgstr ""
"Installieren Sie das ca-certificate Paket oder die benötigten Zertifikate "
"von Hand in das Standardverzeichnis /etc/ssl/certs"
-msgid "Interface"
-msgstr "Schnittstelle"
-
msgid ""
"Interval to check for changed IP<br />Values below 5 minutes == 300 seconds "
"are not supported"
@@ -400,9 +358,6 @@ msgstr ""
msgid "Last Update"
msgstr "Letztes Aktualisierung"
-msgid "Loading"
-msgstr "Lade"
-
msgid "Log File Viewer"
msgstr "Protokolldatei"
@@ -438,9 +393,6 @@ msgstr ""
"Weder GNU Wget mit SSL noch cURL sind installiert um Aktualisierungen über "
"HTTPS Protokoll zu unterstützen."
-msgid "Network"
-msgstr "Netzwerk"
-
msgid "Network on which the ddns-updater scripts will be started"
msgstr "Netzwerk auf dem Ereignisse die ddns-updater Skripte starten"
@@ -462,9 +414,6 @@ msgstr "Keine Protokollierung"
msgid "Non-public and by default blocked IP's"
msgstr "Nicht-öffentliche und standardmäßig blockierte IPs."
-msgid "Notice"
-msgstr "Notiz"
-
msgid "Number of last lines stored in log files"
msgstr ""
"Anzahl der letzten Zeilen die in der Protokolldatei gespeichert werden."
@@ -511,21 +460,12 @@ msgstr "Optional: Ersetzt [PARAMENC] in der Update-URL (URL-codiert)"
msgid "Optional: Replaces [PARAMOPT] in Update-URL (NOT URL-encoded)"
msgstr "Optional: Ersetzt [PARAMENC] in der Update-URL (NICHT URL-codiert)"
-msgid "Overview"
-msgstr "Übersicht"
-
msgid "PROXY-Server"
msgstr "Proxy-Server"
msgid "PROXY-Server not supported"
msgstr "Proxy-Server nicht unterstützt"
-msgid "Password"
-msgstr "Passwort"
-
-msgid "Path to CA-Certificate"
-msgstr "Pfad zum CA-Zertifikat"
-
msgid "Please [Save & Apply] your changes first"
msgstr "Bitte [Speichern & Anwenden] Sie Änderungen zunächst"
@@ -571,9 +511,6 @@ msgstr "Softwareaktualisierung nötig"
msgid "Specifying a DNS-Server is not supported"
msgstr "Die Angabe eines DNS-Server wird nicht unterstützt"
-msgid "Start"
-msgstr "Start"
-
msgid "Start / Stop"
msgstr "Start / Stopp"
@@ -635,27 +572,12 @@ msgstr ""
"Definiert das Skript mit dem die aktuelle IP-Adresse des System gelesen "
"wird."
-msgid "Username"
-msgstr "Benutzername"
-
msgid "Using specific DNS Server not supported"
msgstr "Verwendung spezifischer DNS-Server wird nicht unterstützt"
-msgid "Verify"
-msgstr "überprüfen"
-
-msgid "Version"
-msgstr "Version"
-
msgid "Version Information"
msgstr "Versionsinformationen"
-msgid "Waiting for changes to be applied..."
-msgstr "Änderungen werden angewandt..."
-
-msgid "Warning"
-msgstr "Warnung"
-
msgid ""
"Writes detailed messages to log file. File will be truncated automatically."
msgstr ""
@@ -685,6 +607,13 @@ msgid "You should install BIND host package for DNS requests."
msgstr ""
"Sie sollten das Programmpakete BIND host for DNS Anfragen installieren."
+msgid ""
+"You should install GNU Wget with SSL (prefered) or cURL or uclient-fetch "
+"package."
+msgstr ""
+"Sie sollten das Programmpaket GNU Wget mit SSL (bevorzugt) oder cURL oder "
+"uclient-fetch installieren."
+
msgid "You should install GNU Wget with SSL (prefered) or cURL package."
msgstr ""
"Sie sollten das Programmpaket GNU Wget mit SSL (bevorzugt) oder cURL "
@@ -730,9 +659,6 @@ msgstr "hier aktivieren"
msgid "file or directory not found or not 'IGNORE'"
msgstr "Datei oder Verzeichnis nicht gefunden oder nicht 'IGNORE'"
-msgid "help"
-msgstr "Hilfe"
-
msgid "hours"
msgstr "Stunden"
diff --git a/applications/luci-app-ddns/po/templates/ddns.pot b/applications/luci-app-ddns/po/templates/ddns.pot
index dbe317d13..c76b8e13c 100644
--- a/applications/luci-app-ddns/po/templates/ddns.pot
+++ b/applications/luci-app-ddns/po/templates/ddns.pot
@@ -4,21 +4,12 @@ msgstr "Content-Type: text/plain; charset=UTF-8"
msgid "&"
msgstr ""
-msgid "-- custom --"
-msgstr ""
-
msgid "-- default --"
msgstr ""
-msgid "Advanced Settings"
-msgstr ""
-
msgid "Allow non-public IP's"
msgstr ""
-msgid "Applying changes"
-msgstr ""
-
msgid "Basic Settings"
msgstr ""
@@ -61,15 +52,9 @@ msgstr ""
msgid "Check Interval"
msgstr ""
-msgid "Collecting data..."
-msgstr ""
-
msgid "Config error"
msgstr ""
-msgid "Configuration"
-msgstr ""
-
msgid ""
"Configure here the details for all Dynamic DNS services including this LuCI "
"application."
@@ -160,9 +145,6 @@ msgid ""
"Directory contains PID and other status information for each running section"
msgstr ""
-msgid "Disabled"
-msgstr ""
-
msgid "Domain"
msgstr ""
@@ -177,12 +159,6 @@ msgstr ""
msgid "Enable secure communication with DDNS provider"
msgstr ""
-msgid "Enabled"
-msgstr ""
-
-msgid "Error"
-msgstr ""
-
msgid "Error Retry Counter"
msgstr ""
@@ -192,9 +168,6 @@ msgstr ""
msgid "Event Network"
msgstr ""
-msgid "File"
-msgstr ""
-
msgid "File not found"
msgstr ""
@@ -238,9 +211,6 @@ msgid ""
"interface."
msgstr ""
-msgid "Global Settings"
-msgstr ""
-
msgid "HTTPS not supported"
msgstr ""
@@ -256,9 +226,6 @@ msgstr ""
msgid "IP address version"
msgstr ""
-msgid "IPv4-Address"
-msgstr ""
-
msgid "IPv6 address must be given in square brackets"
msgstr ""
@@ -271,9 +238,6 @@ msgstr ""
msgid "IPv6 not supported"
msgstr ""
-msgid "IPv6-Address"
-msgstr ""
-
msgid "If both cURL and GNU Wget are installed, Wget is used by default."
msgstr ""
@@ -294,17 +258,11 @@ msgid ""
"In some versions cURL/libcurl in OpenWrt is compiled without proxy support."
msgstr ""
-msgid "Info"
-msgstr ""
-
msgid ""
"Install ca-certificates package or needed certificates by hand into /etc/ssl/"
"certs default directory"
msgstr ""
-msgid "Interface"
-msgstr ""
-
msgid ""
"Interval to check for changed IP<br />Values below 5 minutes == 300 seconds "
"are not supported"
@@ -322,9 +280,6 @@ msgstr ""
msgid "Last Update"
msgstr ""
-msgid "Loading"
-msgstr ""
-
msgid "Log File Viewer"
msgstr ""
@@ -356,9 +311,6 @@ msgid ""
"protocol."
msgstr ""
-msgid "Network"
-msgstr ""
-
msgid "Network on which the ddns-updater scripts will be started"
msgstr ""
@@ -380,9 +332,6 @@ msgstr ""
msgid "Non-public and by default blocked IP's"
msgstr ""
-msgid "Notice"
-msgstr ""
-
msgid "Number of last lines stored in log files"
msgstr ""
@@ -422,21 +371,12 @@ msgstr ""
msgid "Optional: Replaces [PARAMOPT] in Update-URL (NOT URL-encoded)"
msgstr ""
-msgid "Overview"
-msgstr ""
-
msgid "PROXY-Server"
msgstr ""
msgid "PROXY-Server not supported"
msgstr ""
-msgid "Password"
-msgstr ""
-
-msgid "Path to CA-Certificate"
-msgstr ""
-
msgid "Please [Save & Apply] your changes first"
msgstr ""
@@ -482,9 +422,6 @@ msgstr ""
msgid "Specifying a DNS-Server is not supported"
msgstr ""
-msgid "Start"
-msgstr ""
-
msgid "Start / Stop"
msgstr ""
@@ -540,27 +477,12 @@ msgstr ""
msgid "User defined script to read systems IP-Address"
msgstr ""
-msgid "Username"
-msgstr ""
-
msgid "Using specific DNS Server not supported"
msgstr ""
-msgid "Verify"
-msgstr ""
-
-msgid "Version"
-msgstr ""
-
msgid "Version Information"
msgstr ""
-msgid "Waiting for changes to be applied..."
-msgstr ""
-
-msgid "Warning"
-msgstr ""
-
msgid ""
"Writes detailed messages to log file. File will be truncated automatically."
msgstr ""
@@ -581,6 +503,11 @@ msgstr ""
msgid "You should install BIND host package for DNS requests."
msgstr ""
+msgid ""
+"You should install GNU Wget with SSL (prefered) or cURL or uclient-fetch "
+"package."
+msgstr ""
+
msgid "You should install GNU Wget with SSL (prefered) or cURL package."
msgstr ""
@@ -620,9 +547,6 @@ msgstr ""
msgid "file or directory not found or not 'IGNORE'"
msgstr ""
-msgid "help"
-msgstr ""
-
msgid "hours"
msgstr ""