summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-11 22:41:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-11 22:41:32 +0000
commit7add578817b9406700022b60aa75012037bc289a (patch)
tree5735e74b18298c620fbf81fcbc46378c84695d41
parent7c72d241faf37ae3fdfe3cb997ad75ef8d230a2c (diff)
protocols: merge pptp into ppp, adjust depends for kernel mode pptp
-rw-r--r--contrib/package/luci/Makefile7
-rw-r--r--protocols/ppp/luasrc/model/cbi/admin_network/proto_pptp.lua (renamed from protocols/pptp/luasrc/model/cbi/admin_network/proto_pptp.lua)0
-rw-r--r--protocols/ppp/luasrc/model/network/proto_ppp.lua6
-rw-r--r--protocols/pptp/Makefile2
4 files changed, 8 insertions, 7 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 4420c7ead..1b6945eb5 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -212,10 +212,9 @@ define protocol
endef
$(eval $(call protocol,core,Support for static/dhcp/none))
-$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA))
-$(eval $(call protocol,pptp,Support for PPtP,+pptp))
-$(eval $(call protocol,6x4,Support for 6in4/6to4,+6in4 +6to4))
-$(eval $(call protocol,3g,Support for 3G,+comgt))
+$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
+$(eval $(call protocol,6x4,Support for 6in4/6to4,+PACKAGE_luci-proto-6x4:6in4 +PACKAGE_luci-proto-6x4:6to4))
+$(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
$(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
diff --git a/protocols/pptp/luasrc/model/cbi/admin_network/proto_pptp.lua b/protocols/ppp/luasrc/model/cbi/admin_network/proto_pptp.lua
index fb8a9ac8a..fb8a9ac8a 100644
--- a/protocols/pptp/luasrc/model/cbi/admin_network/proto_pptp.lua
+++ b/protocols/ppp/luasrc/model/cbi/admin_network/proto_pptp.lua
diff --git a/protocols/ppp/luasrc/model/network/proto_ppp.lua b/protocols/ppp/luasrc/model/network/proto_ppp.lua
index b00c9f0a2..2dded366d 100644
--- a/protocols/ppp/luasrc/model/network/proto_ppp.lua
+++ b/protocols/ppp/luasrc/model/network/proto_ppp.lua
@@ -43,10 +43,12 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g"}) do
end
function proto.opkg_package(self)
- if p == "ppp" or p == "pptp" then
+ if p == "ppp" then
return p
elseif p == "3g" then
return "comgt"
+ elseif p == "pptp" then
+ return "ppp-mod-pptp"
elseif p == "pppoe" then
return "ppp-mod-pppoe"
elseif p == "pppoa" then
@@ -59,6 +61,8 @@ for _, p in ipairs({"ppp", "pptp", "pppoe", "pppoa", "3g"}) do
return (nixio.fs.glob("/usr/lib/pppd/*/pppoatm.so")() ~= nil)
elseif p == "pppoe" then
return (nixio.fs.glob("/usr/lib/pppd/*/rp-pppoe.so")() ~= nil)
+ elseif p == "pptp" then
+ return (nixio.fs.glob("/usr/lib/pppd/*/pptp.so")() ~= nil)
elseif p == "3g" then
return nixio.fs.access("/lib/netifd/proto/3g.sh")
else
diff --git a/protocols/pptp/Makefile b/protocols/pptp/Makefile
deleted file mode 100644
index f7fac7740..000000000
--- a/protocols/pptp/Makefile
+++ /dev/null
@@ -1,2 +0,0 @@
-include ../../build/config.mk
-include ../../build/module.mk