summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorVladimir <picfun@ya.ru>2018-01-23 21:48:28 +0300
committerStan Grishin <stangri@melmac.net>2018-01-25 19:51:03 -0800
commit61cf3442858ddb8794efb91b336113929325e302 (patch)
tree0e532fd09139798c29510bc74e9b53dd9d80c925
parentee409b66ce8911651a985c6e38690c486fefe1d1 (diff)
fixed dynapoint.lua, there was no translation
Signed-off-by: Vladimir <picfun@ya.ru>
-rw-r--r--applications/luci-app-simple-adblock/Makefile5
-rw-r--r--applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua7
2 files changed, 7 insertions, 5 deletions
diff --git a/applications/luci-app-simple-adblock/Makefile b/applications/luci-app-simple-adblock/Makefile
index d7be6850b..31055f120 100644
--- a/applications/luci-app-simple-adblock/Makefile
+++ b/applications/luci-app-simple-adblock/Makefile
@@ -7,9 +7,10 @@ PKG_LICENSE:=GPL-3.0+
PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
LUCI_TITLE:=Simple Adblock Web UI
-LUCI_DEPENDS:=+simple-adblock
+LUCI_DESCRIPTION:=Provides Web UI for simple-adblock service.
+LUCI_DEPENDS:=+luci +simple-adblock
LUCI_PKGARCH:=all
-PKG_RELEASE:=2
+PKG_RELEASE:=5
include ../../luci.mk
diff --git a/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua b/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
index ff4638e9b..e80cfb39e 100644
--- a/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
+++ b/applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua
@@ -11,10 +11,11 @@ end
function e.write(self, section, value)
if value == "1" then
- luci.sys.call("/etc/init.d/simple-adblock enable >/dev/null")
- luci.sys.call("/etc/init.d/simple-adblock start >/dev/null")
+ luci.sys.init.enable("simple-adblock")
+ luci.sys.init.start("simple-adblock")
else
- luci.sys.call("/etc/init.d/simple-adblock stop >/dev/null")
+ luci.sys.init.stop("simple-adblock")
+ luci.sys.init.disable("simple-adblock")
end
return Flag.write(self, section, value)
end