summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 22:43:57 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-09 22:44:15 +0200
commit4d97a9f6986fb37ce7e69a1ca3f4743334495654 (patch)
treeed787f20036e88d54c8378981b2f40622ff6f0af
parente06c60a0d669bed72e495d51f5e30513b05f5605 (diff)
luci-base: use default install paths for host utils
This reverts commit d4c33720208346ee7983213fe764df3102b8a771. PATH inconsistencies and Host/Install arguments have been fixed in both LEDE and OpenWrt, so we can revert the revert. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--luci.mk3
-rw-r--r--modules/luci-base/Makefile7
2 files changed, 4 insertions, 6 deletions
diff --git a/luci.mk b/luci.mk
index eb034d208..84d151230 100644
--- a/luci.mk
+++ b/luci.mk
@@ -150,8 +150,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
define SrcDiet
$(FIND) $(1) -type f -name '*.lua' | while read src; do \
- if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \
- --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
+ if LuaSrcDiet --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
then mv "$$$$src.o" "$$$$src"; fi; \
done
endef
diff --git a/modules/luci-base/Makefile b/modules/luci-base/Makefile
index f0763cb1d..972a451c6 100644
--- a/modules/luci-base/Makefile
+++ b/modules/luci-base/Makefile
@@ -37,10 +37,9 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/bin
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
+ $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
endef
$(eval $(call HostBuild))