summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2019-12-10 13:28:13 +0100
committerFlorian Eckert <fe@dev.tdt.de>2019-12-10 13:28:19 +0100
commit1f84f268cc647d3469864fd9b04b97d4cd2f984c (patch)
tree351b54d122e6d10ea2cba208f4c98ef3f991041e
parentd87169c0f60f9e7c1f8a61b2809473802093ff31 (diff)
luci.mk: move indexcache delete into postinst
Almost every uci-defaults script for ucitrack execute after the uci commands the following line '/tmp/luci-indexcache'. So that we don't always write the same thing, we now do this in postinst. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rw-r--r--luci.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/luci.mk b/luci.mk
index d8fa02951..e6c48ccc6 100644
--- a/luci.mk
+++ b/luci.mk
@@ -218,6 +218,7 @@ ifneq ($(LUCI_DEFAULTS),)
define Package/$(PKG_NAME)/postinst
[ -n "$${IPKG_INSTROOT}" ] || {$(foreach script,$(LUCI_DEFAULTS),
(. /etc/uci-defaults/$(script)) && rm -f /etc/uci-defaults/$(script))
+ rm -f /tmp/luci-indexcache
exit 0
}
endef