summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-01-17 13:52:22 +0000
committerSteven Barth <steven@midlink.org>2009-01-17 13:52:22 +0000
commitb847ba072dc15e4c4de2231f73dc3298c3f34092 (patch)
treec374f2fbcdf17c8ebfbe9e8740afc7c5e281b82d
parentd361c24da419470189552c2967f577d598e9aea5 (diff)
Make fixtime more reliable
-rw-r--r--contrib/package/luci/Makefile1
-rwxr-xr-xmodules/admin-core/root/etc/init.d/luci_fixtime2
2 files changed, 2 insertions, 1 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index d85a93f00..3016adf73 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -283,6 +283,7 @@ endef
define Package/luci-admin-core/install
$(call Package/luci/install/template,$(1),modules/admin-core)
+ touch $(1)/etc/init.d/luci_fixtime || true
endef
diff --git a/modules/admin-core/root/etc/init.d/luci_fixtime b/modules/admin-core/root/etc/init.d/luci_fixtime
index 681d9d789..f300e45b9 100755
--- a/modules/admin-core/root/etc/init.d/luci_fixtime
+++ b/modules/admin-core/root/etc/init.d/luci_fixtime
@@ -5,7 +5,7 @@ START=05
start() {
cat <<' EOF' | lua -l luci.fs -l luci.util -
if (os.time() < 1000000000) then
- os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime(luci.util.libpath())))
+ os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime("/etc/init.d/luci_fixtime")))
end
EOF
}