summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorManuel Munz <freifunk@somakoma.de>2011-02-10 14:58:44 +0000
committerManuel Munz <freifunk@somakoma.de>2011-02-10 14:58:44 +0000
commit6aa6b3b7ebae9f295c06d1fa859c1cf9bf2e979b (patch)
tree582c98df3c203e945ac882f346150743303c1031
parent3a53e9425a11803408bb2c160fec025bf445b6d8 (diff)
applications/luci-olsr-services: Move services away from mod-freifunk and make it seperate app instead.
-rw-r--r--applications/luci-olsr-services/Makefile4
-rw-r--r--applications/luci-olsr-services/luasrc/controller/services.lua17
-rw-r--r--applications/luci-olsr-services/luasrc/view/freifunk-services/services.htm (renamed from modules/freifunk/luasrc/view/freifunk-services/services.htm)0
-rw-r--r--contrib/package/luci/Makefile5
-rw-r--r--modules/freifunk/luasrc/controller/freifunk/freifunk.lua9
5 files changed, 25 insertions, 10 deletions
diff --git a/applications/luci-olsr-services/Makefile b/applications/luci-olsr-services/Makefile
new file mode 100644
index 000000000..572afba3c
--- /dev/null
+++ b/applications/luci-olsr-services/Makefile
@@ -0,0 +1,4 @@
+PO =
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-olsr-services/luasrc/controller/services.lua b/applications/luci-olsr-services/luasrc/controller/services.lua
new file mode 100644
index 000000000..cc1a2f62e
--- /dev/null
+++ b/applications/luci-olsr-services/luasrc/controller/services.lua
@@ -0,0 +1,17 @@
+module "luci.controller.services"
+
+function index()
+ local uci = require "luci.model.uci".cursor()
+ local i18n = luci.i18n.translate
+
+ uci:foreach("olsrd", "LoadPlugin", function(s)
+ if s.library == "olsrd_nameservice.so.0.3" then
+ has_serv = true
+ end
+ end)
+
+ if has_serv then
+ entry({"freifunk", "services"}, template("freifunk-services/services"), i18n("Services"), 60)
+ end
+end
+
diff --git a/modules/freifunk/luasrc/view/freifunk-services/services.htm b/applications/luci-olsr-services/luasrc/view/freifunk-services/services.htm
index c9385cd57..c9385cd57 100644
--- a/modules/freifunk/luasrc/view/freifunk-services/services.htm
+++ b/applications/luci-olsr-services/luasrc/view/freifunk-services/services.htm
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index b6f717065..53aaec115 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -228,7 +228,7 @@ define Package/luci-mod-freifunk-community
+PACKAGE_luci-mod-freifunk-community:olsrd +PACKAGE_luci-mod-freifunk-community:olsrd-mod-dyn-gw-plain \
+PACKAGE_luci-mod-freifunk-community:olsrd-mod-txtinfo +PACKAGE_luci-mod-freifunk-community:olsrd-mod-nameservice \
+PACKAGE_luci-mod-freifunk-community:olsrd-mod-watchdog +PACKAGE_luci-mod-freifunk-community:kmod-tun \
- +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr
+ +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr +luci-app-olsr-services
endef
define Package/luci-mod-freifunk-community/install
@@ -337,6 +337,9 @@ $(eval $(call application,olsr,OLSR configuration and status module,\
$(eval $(call application,olsr-viz,OLSR Visualisation,\
+PACKAGE_luci-app-olsr-viz:luci-app-olsr +PACKAGE_luci-app-olsr-viz:olsrd-mod-txtinfo))
+$(eval $(call application,olsr-services,Show services announced with the nameservice plugin,\
+ +PACKAGE_luci-app-olsr-services:olsrd-mod-nameservice +luci-mod-freifunk +PACKAGE_luci-app-olsr-services:luci-app-olsr))
+
$(eval $(call application,qos,Quality of Service configuration module,\
+PACKAGE_luci-app-qos:qos-scripts))
diff --git a/modules/freifunk/luasrc/controller/freifunk/freifunk.lua b/modules/freifunk/luasrc/controller/freifunk/freifunk.lua
index 154a29917..8fc3244de 100644
--- a/modules/freifunk/luasrc/controller/freifunk/freifunk.lua
+++ b/modules/freifunk/luasrc/controller/freifunk/freifunk.lua
@@ -98,15 +98,6 @@ function index()
entry({"freifunk", "map"}, template("freifunk-map/frame"), i18n("Karte"), 50)
entry({"freifunk", "map", "content"}, template("freifunk-map/map"), nil, 51)
-
- uci:foreach("olsrd", "LoadPlugin", function(s)
- if s.library == "olsrd_nameservice.so.0.3" then
- has_serv = true
- end
- end)
- if has_serv then
- entry({"freifunk", "services"}, template("freifunk-services/services"), i18n("Services"), 60)
- end
end
local function fetch_olsrd()