summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-15 16:02:47 +0000
committerSteven Barth <steven@midlink.org>2008-06-15 16:02:47 +0000
commit3455ee6d8d9eb3c0ee8459adb586a800dadaf737 (patch)
tree2cc4ac0f6df70f8df1e9afd0faccca1ec9f3299f
parent647bc44868000e97763600dbea176307cd4a3ef5 (diff)
* Added support for htdocs module directory
-rwxr-xr-xapplications/luci-splash/htdocs/cgi-bin/luci-splash (renamed from applications/luci-splash/root/www/cgi-bin/luci-splash)0
-rw-r--r--build/config.mk2
-rw-r--r--build/module.mk2
-rw-r--r--libs/cbi/htdocs/luci-static/resources/cbi.js (renamed from libs/cbi/root/www/luci-static/resources/cbi.js)0
-rwxr-xr-xlibs/sgi-haserl/htdocs/cgi-bin/index.cgi (renamed from libs/sgi-haserl/root/www/cgi-bin/index.cgi)0
-rwxr-xr-xlibs/sgi-haserl/htdocs/cgi-bin/luci (renamed from libs/sgi-haserl/root/www/cgi-bin/luci)0
-rwxr-xr-xlibs/sgi-haserl/htdocs/cgi-bin/luci-upload (renamed from libs/sgi-haserl/root/www/cgi-bin/luci-upload)0
-rw-r--r--libs/sgi-haserl/htdocs/index.html (renamed from libs/sgi-haserl/root/www/index.html)0
-rw-r--r--themes/fledermaus/htdocs/luci-static/fledermaus/cascade.css (renamed from themes/fledermaus/root/www/luci-static/fledermaus/cascade.css)0
-rw-r--r--themes/fledermaus/htdocs/luci-static/fledermaus/logo.png (renamed from themes/fledermaus/root/www/luci-static/fledermaus/logo.png)bin4002 -> 4002 bytes
-rw-r--r--themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css (renamed from themes/openwrt.org/root/www/luci-static/openwrt.org/cascade.css)0
11 files changed, 4 insertions, 0 deletions
diff --git a/applications/luci-splash/root/www/cgi-bin/luci-splash b/applications/luci-splash/htdocs/cgi-bin/luci-splash
index c75593fbe..c75593fbe 100755
--- a/applications/luci-splash/root/www/cgi-bin/luci-splash
+++ b/applications/luci-splash/htdocs/cgi-bin/luci-splash
diff --git a/build/config.mk b/build/config.mk
index 81d3e0836..3cf13201f 100644
--- a/build/config.mk
+++ b/build/config.mk
@@ -7,3 +7,5 @@ LUA_LIBRARYDIR = /usr/lib/lua
LUCI_MODULEDIR = $(LUA_MODULEDIR)/luci
LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
+HTDOCS = /www
+
diff --git a/build/module.mk b/build/module.mk
index 4ef3668c8..b85dcda35 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -14,9 +14,11 @@ clean: luaclean
luasource:
mkdir -p dist$(LUA_MODULEDIR)
mkdir -p dist$(LUCI_MODULEDIR)
+ mkdir -p dist$(HTDOCS)
cp -a root/* dist -R 2>/dev/null || true
cp -a luasrc/* dist$(LUCI_MODULEDIR) -R 2>/dev/null || true
cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
+ cp -a htdocs/* dist$(HTDOCS) -R 2>/dev/null || true
for i in $$(find dist -name .svn); do rm $$i -rf; done
luacompile: luasource
diff --git a/libs/cbi/root/www/luci-static/resources/cbi.js b/libs/cbi/htdocs/luci-static/resources/cbi.js
index a3a47aa45..a3a47aa45 100644
--- a/libs/cbi/root/www/luci-static/resources/cbi.js
+++ b/libs/cbi/htdocs/luci-static/resources/cbi.js
diff --git a/libs/sgi-haserl/root/www/cgi-bin/index.cgi b/libs/sgi-haserl/htdocs/cgi-bin/index.cgi
index aae8591c6..aae8591c6 100755
--- a/libs/sgi-haserl/root/www/cgi-bin/index.cgi
+++ b/libs/sgi-haserl/htdocs/cgi-bin/index.cgi
diff --git a/libs/sgi-haserl/root/www/cgi-bin/luci b/libs/sgi-haserl/htdocs/cgi-bin/luci
index fd8e5941a..fd8e5941a 100755
--- a/libs/sgi-haserl/root/www/cgi-bin/luci
+++ b/libs/sgi-haserl/htdocs/cgi-bin/luci
diff --git a/libs/sgi-haserl/root/www/cgi-bin/luci-upload b/libs/sgi-haserl/htdocs/cgi-bin/luci-upload
index 371967ce9..371967ce9 100755
--- a/libs/sgi-haserl/root/www/cgi-bin/luci-upload
+++ b/libs/sgi-haserl/htdocs/cgi-bin/luci-upload
diff --git a/libs/sgi-haserl/root/www/index.html b/libs/sgi-haserl/htdocs/index.html
index 39ba558df..39ba558df 100644
--- a/libs/sgi-haserl/root/www/index.html
+++ b/libs/sgi-haserl/htdocs/index.html
diff --git a/themes/fledermaus/root/www/luci-static/fledermaus/cascade.css b/themes/fledermaus/htdocs/luci-static/fledermaus/cascade.css
index 8f30015f3..8f30015f3 100644
--- a/themes/fledermaus/root/www/luci-static/fledermaus/cascade.css
+++ b/themes/fledermaus/htdocs/luci-static/fledermaus/cascade.css
diff --git a/themes/fledermaus/root/www/luci-static/fledermaus/logo.png b/themes/fledermaus/htdocs/luci-static/fledermaus/logo.png
index d4c5dd9a3..d4c5dd9a3 100644
--- a/themes/fledermaus/root/www/luci-static/fledermaus/logo.png
+++ b/themes/fledermaus/htdocs/luci-static/fledermaus/logo.png
Binary files differ
diff --git a/themes/openwrt.org/root/www/luci-static/openwrt.org/cascade.css b/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
index 90827ab4e..90827ab4e 100644
--- a/themes/openwrt.org/root/www/luci-static/openwrt.org/cascade.css
+++ b/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css