diff options
author | Jo-Philipp Wich <jow@openwrt.org> | 2014-02-05 13:35:34 +0000 |
---|---|---|
committer | Jo-Philipp Wich <jow@openwrt.org> | 2014-02-05 13:35:34 +0000 |
commit | c1bd1e59d3fcdd31ddec9a2795ace53c41993e8b (patch) | |
tree | 302096e173deadb9603af770c2156d9e55d127c2 | |
parent | 6c45ccec6a297ba2bdf2694142c93fc55dfb9193 (diff) |
build: fix clean targets in Makefiles (#667)
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | contrib/uci/Makefile | 1 | ||||
-rw-r--r-- | libs/web/Makefile | 1 |
3 files changed, 3 insertions, 1 deletions
@@ -33,7 +33,7 @@ i18nbuild: clean: rm -f .running-sdk rm -rf docs - make -C libs/lmo host-clean + make -C libs/web host-clean for i in $(MODULES); do make -C$$i clean; done diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile index b0ea8c0b6..d04c5a146 100644 --- a/contrib/uci/Makefile +++ b/contrib/uci/Makefile @@ -39,4 +39,5 @@ compile: $(UCI_DIR)/.prepared compile-all: compile clean: + rm -rf $(UCI_PATCHDIR)/series rm -rf $(UCI_DIR) $(UCI_FILE) diff --git a/libs/web/Makefile b/libs/web/Makefile index 1d28a3a4c..ad16ec737 100644 --- a/libs/web/Makefile +++ b/libs/web/Makefile @@ -41,4 +41,5 @@ host-install: host-compile cp src/$(TPL_PO2LMO) ../../build/$(TPL_PO2LMO) host-clean: + rm -f src/$(TPL_PO2LMO) rm -f ../../build/$(TPL_PO2LMO) |