summaryrefslogtreecommitdiffhomepage
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-05 01:05:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-05 01:05:01 +0000
commitbaa3404ab3e4c56b3583c91af58e554df2f42da2 (patch)
tree791a48ab67bf2163b452541faf2309908e0a7593
parent9835296ba2623b5c87624da3a8ba5f43595297d0 (diff)
trunk: add gzip build target
-rw-r--r--build/module.mk3
-rw-r--r--contrib/package/luci/Makefile7
2 files changed, 10 insertions, 0 deletions
diff --git a/build/module.mk b/build/module.mk
index 8f3964ad6..93f52689c 100644
--- a/build/module.mk
+++ b/build/module.mk
@@ -37,6 +37,9 @@ luastrip: luasource
luacompile: luasource
for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
+luagzip: luacompile
+ for i in $$(find dist -name *.lua -not -name debug.lua); do gzip -9 $$i; done
+
luaclean:
rm -rf dist
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 044eca6ae..ec1a52a17 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -127,6 +127,9 @@ define Package/luci-core/config
config PACKAGE_luci-core_source
bool "Full Source"
+ config PACKAGE_luci-core_zipped
+ bool "Precompiled and compressed"
+
endchoice
endef
@@ -138,6 +141,10 @@ ifneq ($(CONFIG_PACKAGE_luci-core_stripped),)
LUA_TARGET:=strip
endif
+ifneq ($(CONFIG_PACKAGE_luci-core_zipped),)
+ LUA_TARGET:=gzip
+endif
+
### Libraries ###
define Package/luci-cbi